User account creation filtered due to spam.

Bug 30012 - void foo(GLvoid) doesn't work
Summary: void foo(GLvoid) doesn't work
Status: VERIFIED DUPLICATE of bug 9278
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 4.3.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-29 00:35 UTC by Mike Stump
Modified: 2006-11-29 03:08 UTC (History)
7 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Stump 2006-11-29 00:35:25 UTC
$ cat /tmp/t.cc
typedef void GLvoid;
extern void glEndTransformFeedbackEXT(GLvoid);
il0102b-dhcp66 $ ./xgcc -B./ /tmp/t.cc -S
/tmp/t.cc:2: error: '<anonymous>' has incomplete type
/tmp/t.cc:2: error: invalid use of 'GLvoid'
$ gcc-4.0 /tmp/t.cc -S
$ 

This breaks use of some OpenGL by C++.  This is a regression I think from 4.0.
Comment 1 Andrew Pinski 2006-11-29 00:38:33 UTC
And this is invalid code IIRC.
Comment 2 Mike Stump 2006-11-29 00:39:44 UTC
Found in build of fltk-2.0.x-r5547 http://www.fltk.org/ for i686-apple-darwin9.
Comment 3 Andrew Pinski 2006-11-29 00:41:08 UTC
In fact this is a dup of bug 9278 which was fixed in 4.2.0.

*** This bug has been marked as a duplicate of 9278 ***

*** This bug has been marked as a duplicate of 9278 ***
Comment 4 Andrew Pinski 2006-11-29 00:42:52 UTC
there has already been two Defect reports to the C++ standards committee about this:
http://anubis.dkuug.dk/jtc1/sc22/wg21/docs/cwg_closed.html#18
http://www.open-std.org/jtc1/sc22/wg21/docs/cwg_active.html#577
Comment 5 Mike Stump 2006-11-29 00:46:30 UTC
:-(  Oh well, sorry for the noise...
Comment 6 Mike Stump 2006-11-29 00:57:38 UTC
Ah...