User account creation filtered due to spam.

Bug 29882 - gfortran testsuite doesn't recognize warnings and errors
Summary: gfortran testsuite doesn't recognize warnings and errors
Status: RESOLVED DUPLICATE of bug 47750
Alias: None
Product: gcc
Classification: Unclassified
Component: testsuite (show other bugs)
Version: 4.3.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on: 25241
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-17 23:10 UTC by Francois-Xavier Coudert
Modified: 2012-03-02 08:01 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2006-11-24 02:10:43


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francois-Xavier Coudert 2006-11-17 23:10:03 UTC
gfortran.dg/io_constraints_2.f90 issues an error on line 33 instead of a warning, but it still PASSES.
Comment 1 Jerry DeLisle 2006-11-17 23:45:11 UTC
Are you saying that it matches the message text emitted and thinks its OK, but does not recognize that it was an error vs a warning?
Comment 2 Andrew Pinski 2006-11-18 00:04:30 UTC
I think this is a known issue.
There might be a bug about GCC testsuite also.
Comment 3 Andrew Pinski 2006-11-18 02:26:05 UTC
(In reply to comment #2)
> There might be a bug about GCC testsuite also.

And there is PR 25241.
Comment 4 Andrew Pinski 2006-11-24 02:10:43 UTC
Confirmed.
Comment 5 Bernhard Reutner-Fischer 2012-02-27 16:41:41 UTC
I think this is fixed by now ( see PR47750 )?
Comment 6 Bernhard Reutner-Fischer 2012-03-02 08:01:41 UTC
fixed via PR47750

*** This bug has been marked as a duplicate of bug 47750 ***