Bug 29875 - build of gcc-4.1.1 fails
build of gcc-4.1.1 fails
Status: RESOLVED DUPLICATE of bug 26504
Product: gcc
Classification: Unclassified
Component: c
4.1.1
: P3 normal
: ---
Assigned To: Not yet assigned to anyone
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-17 01:25 UTC by lenlen
Modified: 2006-11-17 01:41 UTC (History)
7 users (show)

See Also:
Host: x86_64
Target: avr
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lenlen 2006-11-17 01:25:25 UTC
The build of gcc-4.1.1 for the avr platform on an x86_64 fails.

../configure --prefix=$PREFIX --target=avr --enable-languages=c --disable-nls --disable-libssp --with-dwarf2
make

/root/avr_toolchain/gcc-4.1.1/obj-avr/./gcc/xgcc -B/root/avr_toolchain/gcc-4.1.1/obj-avr/./gcc/ -B/usr/local/avr/avr/bin/ -B/usr/local/avr/avr/lib/ -isystem /usr/local/avr/avr/include -isystem /usr/local/avr/avr/sys-include -O2  -O2 -g -O2   -DIN_GCC -DCROSS_COMPILE   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition  -isystem ./include  -DDF=SF -Dinhibit_libc -mcall-prologues -g  -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED -Dinhibit_libc -I. -I. -I../../gcc -I../../gcc/. -I../../gcc/../include -I../../gcc/../libcpp/include  -DL_fixunssfsi -c ../../gcc/libgcc2.c -o libgcc/./_fixunssfsi.o
../../gcc/libgcc2.c: In function '__fixunssfsi':
../../gcc/libgcc2.c:1499: internal compiler error: in compute_frame_pointer_to_cfa_displacement, at dwarf2out.c:10446
Comment 1 Andrew Pinski 2006-11-17 01:41:30 UTC

*** This bug has been marked as a duplicate of 26504 ***