Bug 29822 - Javac falls over on our regexp implementation
Summary: Javac falls over on our regexp implementation
Status: RESOLVED FIXED
Alias: None
Product: classpath
Classification: Unclassified
Component: classpath (show other bugs)
Version: 0.93
: P3 normal
Target Milestone: 0.93
Assignee: Andrew John Hughes
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-13 23:30 UTC by Andrew John Hughes
Modified: 2006-11-14 00:33 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
Test regex \P{any} (121 bytes, text/x-java)
2006-11-13 23:38 UTC, Andrew John Hughes
Details
Fix to add any support (418 bytes, patch)
2006-11-14 00:32 UTC, Andrew John Hughes
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew John Hughes 2006-11-13 23:30:50 UTC
I got ecj, the generics branch and jamvm to compile Sun's javac (now under the GPL).  But trying to compile with it fails due to our regex implementation:

Caused by: java.util.regex.PatternSyntaxException: At position 7 in regular expression pattern:
At position 0 in regular expression pattern:
unsupported name all
        (\P{all})+
               ^
   at java.util.regex.Pattern.<init>(Pattern.java:113)
   at java.util.regex.Pattern.compile(Pattern.java:152)
   at java.util.regex.Pattern.compile(Pattern.java:134)
   at com.sun.tools.javac.processing.JavacProcessingEnvironment.<clinit>(JavacProcessingEnvironment.java:1218)
   at com.sun.tools.javac.main.JavaCompiler.initProcessAnnotations(JavaCompiler.java:891)
   ...6 more
Caused by: gnu.java.util.regex.REException: At position 7 in regular expression pattern:
At position 0 in regular expression pattern:
unsupported name all
   at gnu.java.util.regex.RE.getRETokenNamedProperty(RE.java:1497)
   at gnu.java.util.regex.RE.initialize(RE.java:1067)
   at gnu.java.util.regex.RE.<init>(RE.java:330)
   at gnu.java.util.regex.RE.initialize(RE.java:723)
   at gnu.java.util.regex.RE.<init>(RE.java:330)
   at gnu.java.util.regex.RE.<init>(RE.java:314)
   at java.util.regex.Pattern.<init>(Pattern.java:108)
   ...10 more
Caused by: gnu.java.util.regex.REException: At position 0 in regular expression pattern:
unsupported name all
   at gnu.java.util.regex.RETokenNamedProperty.getHandler(RETokenNamedProperty.java:263)
   at gnu.java.util.regex.RETokenNamedProperty.<init>(RETokenNamedProperty.java:97)
   at gnu.java.util.regex.RE.getRETokenNamedProperty(RE.java:1493)
   ...16 more
Comment 1 Andrew John Hughes 2006-11-13 23:38:26 UTC
Created attachment 12613 [details]
Test regex \P{any}
Comment 2 Mark Wielaard 2006-11-13 23:43:38 UTC
What unicode category is 'all'? I couldn't immediately find the definition. Ito, do you happen to know?
Comment 3 Andrew John Hughes 2006-11-14 00:32:52 UTC
Created attachment 12614 [details]
Fix to add any support
Comment 4 Andrew John Hughes 2006-11-14 00:33:48 UTC
Attached patch committed on generics branch.  'all' is simply any character (it is inversed and used as 'no matches' in Sun's code).