Bug 29689 - gfortran should use g77-compatible format for error message
Summary: gfortran should use g77-compatible format for error message
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.3.0
: P3 minor
Target Milestone: ---
Assignee: Brooks Moses
URL:
Keywords: diagnostic, patch
Depends on:
Blocks: 19292 29702
  Show dependency treegraph
 
Reported: 2006-11-02 14:01 UTC by Francois-Xavier Coudert
Modified: 2006-11-09 23:17 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work: 4.3.0
Known to fail: 4.1.2 4.2.0
Last reconfirmed: 2006-11-07 04:33:24


Attachments
Proposed patch including testsuite changes (587 bytes, patch)
2006-11-03 02:52 UTC, Brooks Moses
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Francois-Xavier Coudert 2006-11-02 14:01:45 UTC
There's a thread fortran@gcc.gnu.org started from emacs developers wishing that gfortran used a g77-compatible error message format, starting here: http://gcc.gnu.org/ml/fortran/2006-10/msg00751.html The friendly discussion has been a bit heated.

I don't think anybody disagrees with the fact that using an error format closer to the GNU standard would be nice. They usually are reasons behind standards.

On the other hand, there is broad agreement that the "standard GNU error format" offers very poor possibilities for the description of the error locations, especially for multiple-loci errors.
Comment 1 Francois-Xavier Coudert 2006-11-02 14:34:25 UTC
Some incomplete patch proposals here: http://gcc.gnu.org/ml/fortran/2006-10/msg00825.html and there: http://gcc.gnu.org/ml/fortran/2006-11/msg00017.html
Comment 2 Brooks Moses 2006-11-03 02:52:27 UTC
Created attachment 12541 [details]
Proposed patch including testsuite changes

I attempted to send this to the list, but I'm not sure if it went through.  Thus, posting it here; the following text had been included in the email:

Steve Kargl wrote:
> I have stated more than once THE TRIVIAL FIX DOES NOT WORK.
> It causes REGRESSIONS in the gfortran testsuite.  If someone
> wants to fix whatever is causing the regressions, I'll be more
> than happy to commit the patch.

The attached only-slightly-less-trivial patch should fix the 
regressions, although I have not yet tested it to confirm that.

Since my build machine is currently occupied with running CFD 
calculations for my dissertation, would you mind regtesting it?
Comment 3 Jerry DeLisle 2006-11-03 04:07:41 UTC
I will give it a spin
Comment 4 Francois-Xavier Coudert 2006-11-03 14:14:27 UTC
Commited to mainline as revision 118450. Maybe we want to include this into 4.2 before 4.2.0 is released? I think that would be the best thing to do; opinions?
Comment 5 Jerry DeLisle 2006-11-03 16:12:07 UTC
I agree and already tested for Brooks on 4.2 last night.
Comment 6 Thomas Koenig 2006-11-05 21:31:41 UTC
I don't know why I assigned this to myself.  Brooks has
already fixed this.

Unassigning myself.
Comment 7 Brooks Moses 2006-11-07 04:28:24 UTC
Patch posted for 4.2 but not yet approved:
http://gcc.gnu.org/ml/fortran/2006-11/msg00150.html
Comment 8 Brooks Moses 2006-11-09 23:17:21 UTC
Fixed on 4.2: svn 118628.