Bug 29678 - minimally informative gfortran -fbounds-check
Summary: minimally informative gfortran -fbounds-check
Status: RESOLVED DUPLICATE of bug 29677
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.1.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-31 21:46 UTC by Mike Keehan
Modified: 2006-10-31 21:48 UTC (History)
1 user (show)

See Also:
Host: SLES 9 opteron
Target: x86_64-unknown-linux-gnu
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Keehan 2006-10-31 21:46:37 UTC
My boss teared my hair off with heavy sarcasm when we turned on -fbound-check.

The runtime executable proudly reported an array reference out of bounds.

My boss screamed "Which bloody one?!"

While I am very happy to know we have an array reference out of bounds
I can see his point. Could the error message say which array is out of bounds? 

gfortran 4.1.1
Comment 1 Andrew Pinski 2006-10-31 21:48:17 UTC

*** This bug has been marked as a duplicate of 29677 ***