User account creation filtered due to spam.

Bug 29602 - [F2003] I/O specifiers can now be of any kind
Summary: [F2003] I/O specifiers can now be of any kind
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.3.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on: 44292
Blocks: 20585
  Show dependency treegraph
 
Reported: 2006-10-26 08:31 UTC by Francois-Xavier Coudert
Modified: 2014-06-07 07:52 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2010-09-12 15:38:56


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francois-Xavier Coudert 2006-10-26 08:31:45 UTC
A few restrictions were lifted in F2003:
    * The following OPEN numeric values can be of any kind: RECL=
    * The following READ and WRITE numeric values can be of any kind:
REC=, SIZE=
    * The following INQUIRE numeric values can be of any kind:
NEXTREC=, NUMBER=, RECL=, SIZE=
    * In all I/O statements, the following numeric values can be of any
kind: UNIT=, IOSTAT=
Comment 1 Thomas Koenig 2007-05-27 10:30:04 UTC
Setting severity to "enhancement".
Comment 2 Jerry DeLisle 2010-09-12 15:38:56 UTC
When we break abi for kind=8 recl, we should fix all of these. I will assign to myself so I don't forget. Moving out of enhancement status.
Comment 3 Francois-Xavier Coudert 2014-06-07 07:52:07 UTC
This has been fixed since the last comment, as per https://gcc.gnu.org/ml/fortran/2014-06/msg00064.html