Bug 29590 - ice with -Os on legal code
Summary: ice with -Os on legal code
Status: RESOLVED DUPLICATE of bug 29567
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 4.3.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-25 14:28 UTC by David Binderman
Modified: 2006-10-25 14:39 UTC (History)
4 users (show)

See Also:
Host: x86_64-suse-linux-gnu
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
C++ source code (91.93 KB, text/plain)
2006-10-25 14:29 UTC, David Binderman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Binderman 2006-10-25 14:28:18 UTC
I just tried to compile Suse Linux 10.1 package abiword-2.4.5-6 with the new
GNU C compiler version 4.3 snapshot 20061023 on a x86_64 machine.

The compiler said

ap_Menu_Functions.cpp: In function 'EV_Menu_ItemState ap_GetState_SetPosImage(AV_View*, XAP_Menu_Id)':
ap_Menu_Functions.cpp:1588: internal compiler error: in build2_stat, at tree.c:2963
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.

Preprocessed source code attached. Flag -Os required.
Comment 1 David Binderman 2006-10-25 14:29:39 UTC
Created attachment 12489 [details]
C++ source code
Comment 2 Richard Biener 2006-10-25 14:39:36 UTC

*** This bug has been marked as a duplicate of 29567 ***