Bug 29541 - Enable IBM long double format in PowerPC Linux soft float
Summary: Enable IBM long double format in PowerPC Linux soft float
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.2.0
: P3 normal
Target Milestone: 4.3.0
Assignee: Not yet assigned to anyone
URL:
Keywords: ABI
Depends on:
Blocks:
 
Reported: 2006-10-21 21:23 UTC by Andrew Pinski
Modified: 2007-07-09 08:03 UTC (History)
2 users (show)

See Also:
Host:
Target: powerpc*-*-linux-gnu
Build:
Known to work:
Known to fail:
Last reconfirmed: 2006-10-21 21:25:57


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Pinski 2006-10-21 21:23:49 UTC
This is just a reminder that soft float and IBM long double support don't get along on powerpc.  This is a split off from PR 25864 really.
Comment 1 Andrew Pinski 2006-10-21 21:25:57 UTC
Confirmed.
There was talking about this on the mailing list but I cannot find it right now.
Comment 2 joseph@codesourcery.com 2006-10-22 13:20:14 UTC
Subject: Re:  Enable IBM long double format in PowerPC
 Linux soft float

On Sat, 21 Oct 2006, pinskia at gcc dot gnu dot org wrote:

> There was talking about this on the mailing list but I cannot find it right
> now.

This is glibc bug 2749:
http://sources.redhat.com/bugzilla/show_bug.cgi?id=2749
which has all the necessary patches to both GCC and glibc.

To all intents and purposes we have a regression for PowerPC GNU/Linux 
soft-float: current GCC+glibc are broken, pre-4.1 GCC and glibc 2.3 
worked.  In order to fix this regression, a fix to a soft-fp bug is 
needed.  As per the FSF copyright policy, this must go in glibc first.

http://gcc.gnu.org/ml/gcc/2006-03/msg00558.html
says:

  RMS says:

  > The GLIBC developers should accept some conditionals into their
  > source, so that we do not have two diverging versions.  We should all
  > talk together to make this happen.

He doesn't say that they should also accept bug fixes, but I think that 
can be taken for granted.

Steven Munroe has submitted the relevant glibc fixes several times, both 
to libc-alpha (for core glibc) and libc-ports (for ports) and to that 
glibc bug report, but they have not been reviewed.  I have stated on 
libc-alpha that I believe the patches are correct, but I only maintain 
soft-fp for GCC and cannot approve GCC-local changes that are not in 
glibc, and my own soft-fp patches for glibc are not reviewed either.

At this point, I do not believe that the FSF copyright policy is workable 
in the soft-fp case and so ask that the SC revisit it with RMS and the 
glibc SC with a view to obtaining one of the following conclusions:

* Local changes for soft-fp are permitted in GCC (subject to review by GCC 
soft-fp maintainers) until effective and prompt review and commit to glibc 
CVS of such changes is available when they are submitted to glibc.

* In conjunction with the glibc maintainers, agreement is obtained that 
glibc maintainers will review and commit more promptly changes to soft-fp 
since it is imported into GCC and so they have responsibility in this 
regard to more than just its users within glibc.

* glibc maintainers move soft-fp to the glibc ports repository, along with 
the Alpha, Sparc and PowerPC code that uses it, and allow other 
maintainers to maintain the code in the ports repository.

Comment 3 Andrew Pinski 2007-07-09 08:03:41 UTC
This was all fixed in 4.3.0 by a couple of patches, I forget if it was backported to 4.2.x or not.

Closing as fixed.