Bug 29460 - configure: error: libXtst not found, required by java.awt.Robot
Summary: configure: error: libXtst not found, required by java.awt.Robot
Status: RESOLVED DUPLICATE of bug 25026
Alias: None
Product: gcc
Classification: Unclassified
Component: libgcj (show other bugs)
Version: 4.2.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-13 16:11 UTC by Dale Ranta
Modified: 2006-10-16 15:40 UTC (History)
4 users (show)

See Also:
Host: powerpc-apple-darwin8.7.0
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
config.log file from gfortran/ibin/powerpc-apple-darwin8.7.0/libjava (16.85 KB, text/plain)
2006-10-16 12:39 UTC, Dale Ranta
Details
config.log file from /Users/dir/gfortran/ibin (1.37 KB, text/plain)
2006-10-16 12:42 UTC, Dale Ranta
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dale Ranta 2006-10-13 16:11:24 UTC
I am trying to build java with gtk support. I configured with -

 ../gcc/configure --prefix=/usr/local/java --enable-languages=c,c++,java --enable-java-awt=gtk --enable-gtk-cairo --x-includes=/usr/x11R6/include --x-libraries=/usr/x11R6/lib

And I get this output -

checking for pkg-config... /usr/local/bin/pkg-config
checking for gtk+-2.0 >= 2.4... yes
checking GTK_CFLAGS... -I/usr/local/include/gtk-2.0 -I/usr/local/lib/gtk-2.0/include -I/usr/local/include/atk-1.0 -I/usr/local/include/cairo -I/usr/local/include/pango-1.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include  
checking GTK_LIBS... -L/usr/local/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lintl -liconv  
checking for glib-2.0 >= 2.4 gthread-2.0 >= 2.4... yes
checking GLIB_CFLAGS... -D_REENTRANT -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include  
checking GLIB_LIBS... -L/usr/local/lib -lgthread-2.0 -lglib-2.0 -lintl -liconv  
checking for libart-2.0 >= 2.1... yes
checking LIBART_CFLAGS... -I/usr/local/include/libart-2.0  
checking LIBART_LIBS... -L/usr/local/lib -lart_lgpl_2  
checking for XTestQueryExtension in -lXtst... no
configure: error: libXtst not found, required by java.awt.Robot
make[1]: *** [configure-target-libjava] Error 1
make: *** [all] Error 2
[dranta:~/gfortran/ibin] dir% ls /usr/X11R6/lib/libXtst.*
/usr/X11R6/lib/libXtst.6.1.dylib        /usr/X11R6/lib/libXtst.a
/usr/X11R6/lib/libXtst.6.dylib          /usr/X11R6/lib/libXtst.dylib


Since libXtst is where it is supposed to be, it not clear what the problem is.
Comment 1 Tom Tromey 2006-10-13 20:09:55 UTC
The config.log file in the appropriate build directory
(the libjava target directory, or maybe the classpath subdir)
will have more information -- the test program, the command line.
Could you post that info here?
Comment 2 Andrew Pinski 2006-10-14 02:37:35 UTC
Can you attach config.log?
Comment 3 Dale Ranta 2006-10-16 12:39:31 UTC
Created attachment 12442 [details]
config.log file from gfortran/ibin/powerpc-apple-darwin8.7.0/libjava
Comment 4 Dale Ranta 2006-10-16 12:42:55 UTC
Created attachment 12443 [details]
config.log file from /Users/dir/gfortran/ibin
Comment 5 Pawel Sikora 2006-10-16 12:47:27 UTC
this is a dup of PR25026.
Comment 6 Andrew Pinski 2006-10-16 15:40:41 UTC

*** This bug has been marked as a duplicate of 25026 ***