Bug 29409 - Avr-gcc 4.1.1 build fails
Summary: Avr-gcc 4.1.1 build fails
Status: RESOLVED DUPLICATE of bug 26504
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.1.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
Depends on:
Reported: 2006-10-10 06:57 UTC by Egor
Modified: 2006-10-10 16:27 UTC (History)
6 users (show)

See Also:
Known to work:
Known to fail:
Last reconfirmed:


Note You need to log in before you can comment on or make changes to this bug.
Description Egor 2006-10-10 06:57:20 UTC
I tried to build avr-gcc 4.1.1 but i got an error message:
../gcc-4.1.1/gcc/. -I../../gcc-4.1.1/gcc/../include -I../../gcc-4.1.1/gcc/../libcpp/include  -DL_fixunssfsi -c ../../gcc-4.1.1/gcc/libgcc2.c -o libgcc/./_fixunssfsi.o
../../gcc-4.1.1/gcc/libgcc2.c: In function '__fixunssfsi':
../../gcc-4.1.1/gcc/libgcc2.c:1499: internal compiler error: in compute_frame_pointer_to_cfa_displacement, at dwarf2out.c:10446

binutils 2.17 was build in another directory. 
I use Mandriva 2006 with gcc 4.0.1
The configure string for building avr-gcc 4.1.1 was:
"../gcc-4.1.1/configure --prefix=usr/local/avr411 --target=avr --enable-languages=c --disable-nls --disable-libssp --with-dwarf2"
Comment 1 Andrew Pinski 2006-10-10 16:27:41 UTC
Already fixed for 4.1.2.

*** This bug has been marked as a duplicate of 26504 ***