Bug 29395 - failure in implied do loop data initialization
Summary: failure in implied do loop data initialization
Status: RESOLVED DUPLICATE of bug 23232
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.2.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: rejects-valid
Depends on: 23232
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-08 21:41 UTC by Francois-Xavier Coudert
Modified: 2006-10-08 21:59 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2006-10-08 21:42:51


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francois-Xavier Coudert 2006-10-08 21:41:33 UTC
$ cat a10.f90 
  integer :: i(2,2)
  data ((i(k,j), j = 1, k), k = 1, 2) / 3 * 0 / 
  end 
$ gfortran a10.f90 
 In file a10.f90:2

  data ((i(k,j), j = 1, k), k = 1, 2) / 3 * 0 / 
                      1
Error: Parameter 'k' at (1) has not been declared or is a variable, which does not reduce to a constant expression
Comment 1 Andrew Pinski 2006-10-08 21:44:54 UTC
This looks related to PR 23232 or really a dup.
Comment 2 Francois-Xavier Coudert 2006-10-08 21:59:20 UTC

*** This bug has been marked as a duplicate of 23232 ***