User account creation filtered due to spam.

Bug 29377 - Build for h8300-elf crashes on 64bit hosts due to int/HWI mismatch
Summary: Build for h8300-elf crashes on 64bit hosts due to int/HWI mismatch
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.2.0
: P3 normal
Target Milestone: 4.0.4
Assignee: Uroš Bizjak
URL: http://gcc.gnu.org/ml/gcc-patches/200...
Keywords: build, patch
: 25272 44880 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-10-07 07:50 UTC by Uroš Bizjak
Modified: 2010-07-08 22:10 UTC (History)
3 users (show)

See Also:
Host: x86_64-pc-linux-gnu
Target: h8300-elf
Build: x86_64-pc-linux-gnu
Known to work: 4.0.4 4.1.2 4.3.0 4.2.0
Known to fail:
Last reconfirmed: 2006-10-28 09:43:15


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uroš Bizjak 2006-10-07 07:50:26 UTC
Build for h8300-elf target crashes on 64bit hosts with:

../../gcc-svn/trunk/gcc/libgcc2.c: In function '__muldi3':
../../gcc-svn/trunk/gcc/libgcc2.c:542: error: unrecognizable insn:
(insn 234 233 235 2 ../../gcc-svn/trunk/gcc/libgcc2.c:533 (set (reg:HI 3 r3)
        (const_int 4294967214 [0xffffffae])) -1 (nil)
    (nil))
../../gcc-svn/trunk/gcc/libgcc2.c:542: internal compiler error: in extract_insn, at recog.c:2077
Comment 1 Uroš Bizjak 2006-10-07 07:51:43 UTC
Propsoed patch at http://gcc.gnu.org/ml/gcc-patches/2006-10/msg00337.html
Comment 2 uros 2006-10-28 09:41:51 UTC
Subject: Bug 29377

Author: uros
Date: Sat Oct 28 09:41:41 2006
New Revision: 118102

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=118102
Log:
        PR target/29377
        * config/h8300/h8300.c (h8300_emit_stack_adjustment): Change "size"
        argument to HOST_WIDE_INT.  Update function prototype.
        (round_frame_size): Change return type to HOST_WIDE_INT.  Change
        "size" argument to HOST_WIDE_INT.  Update function prototype.


Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/config/h8300/h8300.c

Comment 3 Uroš Bizjak 2006-10-28 09:43:15 UTC
Fixed on 4.3 mainline
Comment 4 uros 2006-10-28 10:03:50 UTC
Subject: Bug 29377

Author: uros
Date: Sat Oct 28 10:03:37 2006
New Revision: 118103

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=118103
Log:
        PR target/29377
        * config/h8300/h8300.c (h8300_emit_stack_adjustment): Change "size"
        argument to HOST_WIDE_INT.  Update function prototype.
        (round_frame_size): Change return type to HOST_WIDE_INT.  Change
        "size" argument to HOST_WIDE_INT.  Update function prototype.


Modified:
    branches/gcc-4_1-branch/gcc/ChangeLog
    branches/gcc-4_1-branch/gcc/config/h8300/h8300.c

Comment 5 Uroš Bizjak 2006-10-28 10:04:34 UTC
Fixed for 4.1.2.
Comment 6 uros 2006-11-02 07:42:16 UTC
Subject: Bug 29377

Author: uros
Date: Thu Nov  2 07:42:05 2006
New Revision: 118410

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=118410
Log:
        PR target/29377
        * config/h8300/h8300.c (h8300_emit_stack_adjustment): Change "size"
        argument to HOST_WIDE_INT.  Update function prototype.
        (round_frame_size): Change return type to HOST_WIDE_INT.  Change
        "size" argument to HOST_WIDE_INT.  Update function prototype.


Modified:
    branches/gcc-4_2-branch/gcc/ChangeLog
    branches/gcc-4_2-branch/gcc/config/h8300/h8300.c

Comment 7 uros 2006-11-02 07:55:44 UTC
Subject: Bug 29377

Author: uros
Date: Thu Nov  2 07:55:35 2006
New Revision: 118411

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=118411
Log:
        PR target/29377
        * config/h8300/h8300.c (h8300_emit_stack_adjustment): Change "size"
        argument to HOST_WIDE_INT.  Update function prototype.
        (round_frame_size): Change return type to HOST_WIDE_INT.  Change
        "size" argument to HOST_WIDE_INT.  Update function prototype.


Modified:
    branches/gcc-4_0-branch/gcc/ChangeLog
    branches/gcc-4_0-branch/gcc/config/h8300/h8300.c

Comment 8 Uroš Bizjak 2006-11-02 07:57:31 UTC
Fixed everywhere.
Comment 9 Jeffrey A. Law 2010-02-24 19:12:48 UTC
*** Bug 25272 has been marked as a duplicate of this bug. ***
Comment 10 Andrew Pinski 2010-07-08 22:10:57 UTC
*** Bug 44880 has been marked as a duplicate of this bug. ***