Bug 29310 - GCC 4.1.1 fails to bootstrap on a dual G4 Machine (PowerPC 7450 processor)
Summary: GCC 4.1.1 fails to bootstrap on a dual G4 Machine (PowerPC 7450 processor)
Status: RESOLVED DUPLICATE of bug 25127
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 4.1.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-01 18:35 UTC by Andrei
Modified: 2006-10-01 20:20 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei 2006-10-01 18:35:52 UTC
Hello. Today i tried to bootstrap gcc on my G4 machine (OS X 10.4.8 aka Tiger)
The first stage of bootstrapping finished successfully but at a certain point gcc spit some errors:
./xgcc -B./ -B/usr/local/powerpc-apple-darwin8/bin/ -isystem /usr/local/powerpc-apple-darwin8/include -isystem /usr/local/powerpc-apple-darwin8/sys-include -L/Volumes/Titanium/build/gcc/../ld -O2  -O2 -O2 -mcpu=7450 -pipe -fomit-frame-pointer   -DIN_GCC    -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition  -isystem ./include  -Wa,-force_cpusubtype_ALL -pipe -g -DHAVE_GTHR_DEFAULT -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED  -I. -I. -I../../gcc-4.1.1/gcc -I../../gcc-4.1.1/gcc/. -I../../gcc-4.1.1/gcc/../include -I../../gcc-4.1.1/gcc/../libcpp/include  -fexceptions -fvisibility=hidden -DHIDE_EXPORTS -c ../../gcc-4.1.1/gcc/unwind-dw2.c -o libgcc/./unwind-dw2.o
../../gcc-4.1.1/gcc/unwind.inc: In function '_Unwind_RaiseException':
../../gcc-4.1.1/gcc/unwind.inc:140: internal compiler error: in rs6000_emit_prologue, at config/rs6000/rs6000.c:14092
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
{standard input}:3988:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000010$pb"
{standard input}:3988:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3984:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000010$pb"
{standard input}:3984:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3870:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000009$pb"
{standard input}:3870:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3869:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000009$pb"
{standard input}:3869:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3824:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000009$pb"
{standard input}:3824:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3757:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000009$pb"
{standard input}:3757:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3749:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000009$pb"
{standard input}:3749:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3566:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000008$pb"
{standard input}:3566:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3562:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000008$pb"
{standard input}:3562:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3556:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000008$pb"
{standard input}:3556:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3498:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000008$pb"
{standard input}:3498:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3490:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000008$pb"
{standard input}:3490:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3489:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000008$pb"
{standard input}:3489:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3480:non-relocatable subtraction expression, "_once_regsizes.7311" minus "L00000000008$pb"
{standard input}:3480:symbol: "_once_regsizes.7311" can't be undefined in a subtraction expression
{standard input}:3478:non-relocatable subtraction expression, "_once_regsizes.7311" minus "L00000000008$pb"
{standard input}:3478:symbol: "_once_regsizes.7311" can't be undefined in a subtraction expression
{standard input}:3352:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000007$pb"
{standard input}:3352:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3351:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000007$pb"
{standard input}:3351:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3317:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000007$pb"
{standard input}:3317:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:3313:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000007$pb"
{standard input}:3313:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:2829:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000006$pb"
{standard input}:2829:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:2828:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000006$pb"
{standard input}:2828:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:2762:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000006$pb"
{standard input}:2762:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:2758:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000006$pb"
{standard input}:2758:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:2677:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000006$pb"
{standard input}:2677:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:2673:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000006$pb"
{standard input}:2673:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:2388:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000006$pb"
{standard input}:2388:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:2387:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000006$pb"
{standard input}:2387:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:649:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000004$pb"
{standard input}:649:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:648:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000004$pb"
{standard input}:648:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:647:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000004$pb"
{standard input}:647:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:340:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000002$pb"
{standard input}:340:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:336:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000002$pb"
{standard input}:336:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:279:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000001$pb"
{standard input}:279:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:275:non-relocatable subtraction expression, "_dwarf_reg_size_table" minus "L00000000001$pb"
{standard input}:275:symbol: "_dwarf_reg_size_table" can't be undefined in a subtraction expression
{standard input}:unknown:Undefined local symbol L_abort$stub
{standard input}:unknown:Undefined local symbol L__Unwind_Find_FDE$stub
{standard input}:unknown:Undefined local symbol L_memcpy$stub
{standard input}:unknown:Undefined local symbol L_memset$stub
{standard input}:unknown:Undefined local symbol L__Unwind_fallback_frame_state_for$stub
{standard input}:unknown:Undefined local symbol L_strlen$stub
{standard input}:unknown:Undefined local symbol L_pthread_once$stub
make[3]: *** [libgcc/./unwind-dw2.o] Error 1
make[2]: *** [libgcc.a] Error 2
make[1]: *** [stage1_build] Error 2
make: *** [bootstrap] Error 2
Titanium:/Volumes/Titanium/build root# ls
Makefile                        gcc
build-powerpc-apple-darwin8     intl
config.cache                    libcpp
config.log                      libiberty
config.status                   serdep.tmp
Titanium:/Volumes/Titanium/build root#

Note that the initial compiler (the  one used for the first stage bootstrap is gcc 4.0.1 which comes by default ith XCode 2.4)
Here are the specs:
Titanium:/Volumes/Titanium/build root# gcc --v
Using built-in specs.
Target: powerpc-apple-darwin8
Configured with: /private/var/tmp/gcc/gcc-5363.obj~28/src/configure --disable-checking -enable-werror --prefix=/usr --mandir=/share/man --enable-languages=c,objc,c++,obj-c++ --program-transform-name=/^[cg][^.-]*$/s/$/-4.0/ --with-gxx-include-dir=/include/c++/4.0.0 --with-slibdir=/usr/lib --build=powerpc-apple-darwin8 --host=powerpc-apple-darwin8 --target=powerpc-apple-darwin8
Thread model: posix
gcc version 4.0.1 (Apple Computer, Inc. build 5363)
Titanium:/Volumes/Titanium/build root#

If any other information is needed, I will submit it asap.
Comment 1 Andrew Pinski 2006-10-01 20:19:37 UTC
This is a dup of bug 25127.  The work-around is not to use --with-cpu=7450 or --with-cpu=7400.

*** This bug has been marked as a duplicate of 25127 ***
Comment 2 Andrew Pinski 2006-10-01 20:20:15 UTC
Or make sure you don't have "-mcpu=7450" in your Cflags.