Bug 29189 - Error during CPP build of Mozilla
Summary: Error during CPP build of Mozilla
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.1.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-23 04:25 UTC by giffordj
Modified: 2011-12-09 09:05 UTC (History)
1 user (show)

See Also:
Host: powerpc-unknown-linux-gnu
Target: powerpc-unknown-linux-gnu
Build: powerpc-unknown-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments
All files in Dir with -save-temps (179.15 KB, application/octet-stream)
2006-09-23 04:26 UTC, giffordj
Details
All files from -save-temp (179.15 KB, application/octet-stream)
2006-09-23 05:44 UTC, giffordj
Details
Attempt #3 at attaching -save-temp info (245.68 KB, application/x-bzip2)
2006-09-23 20:27 UTC, giffordj
Details

Note You need to log in before you can comment on or make changes to this bug.
Description giffordj 2006-09-23 04:25:19 UTC
Bug on Mozilla side for Reference
https://bugzilla.mozilla.org/show_bug.cgi?id=342472

When trying to build any mozllia program with GCC 4.0 and greater build fails
c++ -save-temps -I/usr/X11R7/include -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic -mcpu=G3 -mtune=G3 -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -mcpu=G3 -mtune=G3 -fno-strict-aliasing -O1 -fPIC -shared -Wl,-h -Wl,libxpcom_compat.so -o libxpcom_compat.so  nsFileSpec.o nsFileStream.o nsIFileStream.o nsFileSpecImpl.o nsSpecialSystemDirectory.o       -Wl,--whole-archive ../../dist/lib/libmozreg_s.a  -Wl,--no-whole-archive  -L../../dist/bin -lxpcom -lxpcom_core  -L../../dist/bin -L/usr/lib -lplds4 -lplc4 -lnspr4 -lpthread -ldl -ldl -lm
c++: warning: -pipe ignored because -save-temps specified
nsSpecialSystemDirectory.o: In function `nsSpecialSystemDirectory::Set(nsSpecialSystemDirectory::SystemDirectories, nsFileSpec*)':
nsSpecialSystemDirectory.cpp:(.text+0x1d0): undefined reference to `nsHashtable::nsHashtable(unsigned int, int)'
nsSpecialSystemDirectory.cpp:(.text+0x204): undefined reference to `nsHashtable::Put(nsHashKey*, void*)'
nsSpecialSystemDirectory.cpp:(.text+0x214): undefined reference to `nsHashKey::~nsHashKey()'
nsSpecialSystemDirectory.o: In function `nsSpecialSystemDirectory::operator=(nsSpecialSystemDirectory::SystemDirectories)':
nsSpecialSystemDirectory.cpp:(.text+0x3d0): undefined reference to `nsHashtable::Get(nsHashKey*)'
nsSpecialSystemDirectory.cpp:(.text+0x3fc): undefined reference to `nsHashtable::Get(nsHashKey*)'
nsSpecialSystemDirectory.cpp:(.text+0x448): undefined reference to `nsHashtable::Get(nsHashKey*)'
nsSpecialSystemDirectory.cpp:(.text+0x474): undefined reference to `nsHashtable::Get(nsHashKey*)'
nsSpecialSystemDirectory.cpp:(.text+0x4c0): undefined reference to `nsHashtable::Get(nsHashKey*)'
nsSpecialSystemDirectory.cpp:(.text+0x52c): undefined reference to `nsHashKey::~nsHashKey()'
nsSpecialSystemDirectory.cpp:(.text+0x538): undefined reference to `nsHashKey::~nsHashKey()'
nsSpecialSystemDirectory.o: In function `SystemDirectoriesKey::~SystemDirectoriesKey()':
nsSpecialSystemDirectory.cpp:(.text._ZN20SystemDirectoriesKeyD0Ev[SystemDirectoriesKey::~SystemDirectoriesKey()]+0x34): undefined reference to `nsHashKey::~nsHashKey()'
nsSpecialSystemDirectory.o: In function `SystemDirectoriesKey::~SystemDirectoriesKey()':
nsSpecialSystemDirectory.cpp:(.text._ZN20SystemDirectoriesKeyD1Ev[SystemDirectoriesKey::~SystemDirectoriesKey()]+0x2c): undefined reference to `nsHashKey::~nsHashKey()'
collect2: ld returned 1 exit status
make[2]: *** [libxpcom_compat.so] Error 1
make[2]: Leaving directory `/usr/src/seamonkey-build/xpcom/obsolete'
make[1]: *** [tier_2] Error 2
make[1]: Leaving directory `/usr/src/seamonkey-build'
make: *** [default] Error 2
Comment 1 giffordj 2006-09-23 04:26:08 UTC
Created attachment 12311 [details]
All files in Dir with -save-temps
Comment 2 giffordj 2006-09-23 04:26:50 UTC
Failures only occur on PPC, no other architecture seems to be affected.
Comment 3 Andrew Pinski 2006-09-23 04:33:27 UTC
Well the bzip file is messed up, can you reattach it?
Comment 4 giffordj 2006-09-23 05:44:27 UTC
Created attachment 12312 [details]
All files from -save-temp
Comment 5 giffordj 2006-09-23 05:44:59 UTC
If that doesn't work, try http://ftp.jg555.com/obsolete.tar.bz2
Comment 6 Andrew Pinski 2006-09-23 05:59:00 UTC
I still get:

bzip2: Compressed file ends unexpectedly;
	perhaps it is corrupted?  *Possible* reason follows.
bzip2: No such file or directory
	Input file = /tmp/fr-GRhwUv/obsolete.tar-1.bz2, output file = /tmp/fr-GRhwUv/obsolete.tar-1

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

bzip2: Deleting output file /tmp/fr-GRhwUv/obsolete.tar-1, if it exists.
Comment 7 Andrew Pinski 2006-09-23 05:59:21 UTC
(In reply to comment #6)
> I still get:
Even with the link in comment #5.
Comment 8 giffordj 2006-09-23 20:27:39 UTC
Created attachment 12317 [details]
Attempt #3 at attaching -save-temp info
Comment 9 Andrew Pinski 2006-09-25 06:07:20 UTC
bl _ZN11nsHashtableC1Eji@local
Comment 10 giffordj 2006-09-29 17:18:18 UTC
Is more information required, let me know.
Comment 11 Manuel López-Ibáñez 2010-02-14 20:07:01 UTC
Is this still an issue? 4.1 is too old already.
Comment 12 Sean McGovern 2011-12-08 19:06:11 UTC
Please close this bug, unless it is still reproducible with a supported version of GCC.
Comment 13 Richard Biener 2011-12-09 09:05:39 UTC
.