Bug 29093 - gcc.dg/debug/dwarf2/dwarf-file1.c fails on targets that have .loc
Summary: gcc.dg/debug/dwarf2/dwarf-file1.c fails on targets that have .loc
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: testsuite (show other bugs)
Version: 4.2.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 29110 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-09-14 23:49 UTC by Andrew Pinski
Modified: 2006-10-12 17:36 UTC (History)
3 users (show)

See Also:
Host:
Target: i686-linux-gnu
Build:
Known to work:
Known to fail:
Last reconfirmed: 2006-09-16 20:57:38


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Andrew Pinski 2006-09-14 23:57:54 UTC
In fact it fails on all targets that have DWARF2_ASM_LINE_DEBUG_INFO as true.
Comment 2 Andrew Pinski 2006-09-16 20:56:58 UTC
*** Bug 29110 has been marked as a duplicate of this bug. ***
Comment 3 Andrew Pinski 2006-09-16 20:57:38 UTC
Confirmed via the dup and the testresults that I pointed to.
Comment 4 Steve Ellcey 2006-10-12 16:52:42 UTC
Subject: Bug 29093

Author: sje
Date: Thu Oct 12 16:52:33 2006
New Revision: 117667

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=117667
Log:
	PR testsuite/29093
	* gcc.dg/debug/dwarf2/dwarf-file1.c: Check for ".file".

Modified:
    trunk/gcc/testsuite/ChangeLog
    trunk/gcc/testsuite/gcc.dg/debug/dwarf2/dwarf-file1.c

Comment 5 Steve Ellcey 2006-10-12 17:36:13 UTC
Fixed with a testsuite change to check for "File Entry:" or ".file".  Platforms that set DWARF2_ASM_LINE_DEBUG_INFO will output a ".file" line but not a "File Entry:" line and the test now checks for either.