Bug 28907 - [4.2 regression] ICE tree check: did not expect class 'type', have 'type' (template_type_parm) in contains_placeholder_p, at tree.c:2223
Summary: [4.2 regression] ICE tree check: did not expect class 'type', have 'type' (te...
Status: RESOLVED DUPLICATE of bug 28906
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 4.2.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-30 16:56 UTC by Martin Michlmayr
Modified: 2006-08-30 17:18 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
test case (222 bytes, text/plain)
2006-08-30 16:57 UTC, Martin Michlmayr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Michlmayr 2006-08-30 16:56:41 UTC
ICE. Works with gcc 4.2 20060806, fails with 20060823.

(sid)630:tbm@usurper: ~] /usr/lib/gcc-snapshot/bin/g++ -c ragel-parsedata.cc
ragel-parsedata.cc:19: internal compiler error: tree check: did not expect class 'type', have 'type' (template_type_parm) in contains_placeholder_p, at tree.c:2223
Comment 1 Martin Michlmayr 2006-08-30 16:57:11 UTC
Created attachment 12157 [details]
test case

Testcase from application "ragel".
Comment 2 Andrew Pinski 2006-08-30 17:18:24 UTC
It is the same bug as PR 28906.

*** This bug has been marked as a duplicate of 28906 ***