Bug 28837 - need to prune "can't find atom for N_GSYM stabs" warnings on Darwin for -m64
Summary: need to prune "can't find atom for N_GSYM stabs" warnings on Darwin for -m64
Status: RESOLVED WONTFIX
Alias: None
Product: gcc
Classification: Unclassified
Component: testsuite (show other bugs)
Version: 4.2.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-24 15:40 UTC by Jack Howarth
Modified: 2008-11-26 12:46 UTC (History)
1 user (show)

See Also:
Host: powerpc-apple-darwin8
Target: powerpc-apple-darwin8
Build: powerpc-apple-darwin8
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jack Howarth 2006-08-24 15:40:24 UTC
Currently the ld64 on Darwin seems to create warnings of the form...

can't find atom for N_GSYM stabs i:G(0,2) in /var/tmp//cc6KtMzX.o

when compiling Fortran COMMON blocks at -m64 with the -g flag. These warnings
incorrectly cause about 38 apparent fortran testsuite failures on Darwin. This
problem can be suppressed until the issue causing the warnings (whose cause is
currently unknown) is addressed. The following patch (sorry about the unified
format) allows these warnings to be pruned and ignored during a -m64 make check.

--- gcc-4.2-20060822/gcc/testsuite/lib/prune.exp.org    2006-08-23 18:33:56.000000000 -0400
+++ gcc-4.2-20060822/gcc/testsuite/lib/prune.exp        2006-08-23 18:41:28.000000000 -0400
@@ -43,6 +43,7 @@
     regsub -all "(^|\n)\[^\n\]*file path prefix \[^\n\]* never used" $text "" text
     regsub -all "(^|\n)\[^\n\]*linker input file unused since linking not done" $text "" text
 
+    regsub -all "(^|\n)can't find atom for N_GSYM stabs \[^\n\]* in \[^\n\]*" $text "" text
     #send_user "After:$text\n"
 
     return $text

With this patch in place the fortran testsuite failures for -m64 are identical 
to those for -m32 with three unexpected passes. This patch will help remove
the "noise" off of the Darwin -m64 test results.
Comment 1 Geoff Keating 2006-10-03 20:50:04 UTC
The patch here is clearly wrong.  If you don't like the warnings, you should work out why they are being output and fix the underlying bug, rather than ignoring them in the testsuite.
Comment 2 Dominique d'Humieres 2007-09-13 06:39:03 UTC
The (spurious?) warning is also present in 4.3.

> The patch here is clearly wrong.  If you don't like the warnings, you should
> work out why they are being output and fix the underlying bug, rather than
> gnoring them in the testsuite.

The patch may be wrong, but so far nobody cared to fix the "underlying bug" or even bothered to explain its origin and how to fix it!-(
Comment 3 Jack Howarth 2007-09-13 13:07:01 UTC
This issue is eliminated in Xcode 3.0 of Leopard. I've updated my original radar bug report to ask that the fix be backported to Xcode 2.5 so that it is available on Tiger as well but I wouldn't hold my breath.
Comment 4 Jack Howarth 2008-11-26 12:46:44 UTC
This issue won't be fixed in the Xcode available for darwin8. It is resolved in Xcode for darwin9.