Bug 28822 - The 'html' target fails to build for libjava/classpath.
Summary: The 'html' target fails to build for libjava/classpath.
Status: RESOLVED FIXED
Alias: None
Product: classpath
Classification: Unclassified
Component: classpath (show other bugs)
Version: 0.92
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-23 15:25 UTC by Carlos O'Donell
Modified: 2007-11-25 21:37 UTC (History)
2 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos O'Donell 2006-08-23 15:25:48 UTC
If libjava is not configured with --with-gjdoc, and 'make html' is run from the top-level, the library fails to build because $(GJDOC) is not defined.

Would it be possible for the configury to determine if gjdoc is installed, and setup the correct --with-gjdoc options?

With this pr complete, we can test 'make html' for all languages and prevent target bit rot.
Comment 1 cvs-commit@developer.classpath.org 2006-11-25 14:56:10 UTC
Subject: Bug 28822

CVSROOT:	/cvsroot/classpath
Module name:	classpath
Changes by:	Mark Wielaard <mark>	06/11/25 14:55:43

Modified files:
	.              : ChangeLog 
	doc/api        : Makefile.am 

Log message:
	        Fixes bug #28822
	        * doc/api/Makefile.am (create_html): Guard GJDOC invocation with
	        CREATE_API_DOCS

CVSWeb URLs:
http://cvs.savannah.gnu.org/viewcvs/classpath/ChangeLog?cvsroot=classpath&r1=1.8849&r2=1.8850
http://cvs.savannah.gnu.org/viewcvs/classpath/doc/api/Makefile.am?cvsroot=classpath&r1=1.19&r2=1.20



Comment 2 Mark Wielaard 2007-11-25 21:37:46 UTC
make html now also works from gcc toplevel dir.