Bug 28815 - gcc-4.2-20060819 failed to compile Linux kernel 2.6.18-rc4-git1
Summary: gcc-4.2-20060819 failed to compile Linux kernel 2.6.18-rc4-git1
Status: RESOLVED DUPLICATE of bug 28776
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 4.2.0
: P3 critical
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on: 28776
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-23 03:42 UTC by happyarch
Modified: 2006-08-24 10:39 UTC (History)
9 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description happyarch 2006-08-23 03:42:19 UTC
Hi,

I had upgraded my gcc version 4.2.0 20060812 (experimental) to it.
But when i tried to compile newer linux kernel, it failed whereas my returned previous gcc version 4.2.0 20060812 was fine.
Comment 1 Martin Michlmayr 2006-08-23 05:42:39 UTC
What error did you get?  Can you please paste the error message.
Comment 2 Martin Michlmayr 2006-08-23 05:56:15 UTC
And please consult http://gcc.gnu.org/bugs.html
Comment 3 happyarch 2006-08-23 06:34:33 UTC
Hi,

Arrgh, then i have to compile gcc 819 again,
Usually, i keep store previous successful gcc version in temp,
But, remove all failed gcc version.

Anyway it was internal-gcc error and was happened when i "make" in
kernel root directory, if you really want to see the error message,
let me know.
Comment 4 Andrew Pinski 2006-08-23 07:07:07 UTC
Yes we need the error message and the preprocessed source and what exact version of GCC you are using and what target you are compiling for.
Comment 5 happyarch 2006-08-24 01:16:09 UTC
I am using binutils-2.17, glibc-2.4 and gcc, kernel version is in the below error message.

 > make
scripts/kconfig/conf -s arch/i386/Kconfig
  CHK     include/linux/version.h
  CHK     include/linux/utsrelease.h
...

  CC      kernel/configs.o
  CC      kernel/ksysfs.o
  CC      kernel/seccomp.o
  CC      kernel/relay.o
  LD      kernel/built-in.o
  CC      mm/bootmem.o
  CC      mm/filemap.o
  CC      mm/mempool.o
  CC      mm/oom_kill.o
  CC      mm/fadvise.o
  CC      mm/page_alloc.o
  CC      mm/page-writeback.o
  CC      mm/pdflush.o
  CC      mm/readahead.o
  CC      mm/swap.o
  CC      mm/truncate.o
  CC      mm/vmscan.o
  CC      mm/prio_tree.o
  CC      mm/util.o
  CC      mm/mmzone.o
  CC      mm/vmstat.o
  CC      mm/fremap.o
  CC      mm/highmem.o
  CC      mm/madvise.o
  CC      mm/memory.o
  CC      mm/mincore.o
  CC      mm/mlock.o
  CC      mm/mmap.o
  CC      mm/mprotect.o
  CC      mm/mremap.o
  CC      mm/msync.o
  CC      mm/rmap.o
  CC      mm/vmalloc.o
  CC      mm/page_io.o
  CC      mm/swap_state.o
  CC      mm/swapfile.o
  CC      mm/thrash.o
  CC      mm/shmem.o
  CC      mm/slab.o
  LD      mm/built-in.o
  CC      fs/open.o
  CC      fs/read_write.o
  CC      fs/file_table.o
  CC      fs/buffer.o
fs/buffer.c: In function 'nobh_prepare_write':
fs/buffer.c:2378: internal compiler error: in build_polynomial_chrec, at tree-chrec.h:108
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
make[1]: *** [fs/buffer.o] Error 1
make: *** [fs] Error 2
 > pwd
/usr/src/linux-2.6.18-rc4
 > cc -v
Using built-in specs.
Target: i686-pc-linux-gnu
Configured with: ../gcc/configure --prefix=/usr --libexecdir=/usr/lib --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --enable-languages=c,c++,treelang
Thread model: posix
gcc version 4.2.0 20060819 (experimental)
 > uname -a
Linux arch 2.6.18-rc4-git1 #3 PREEMPT Tue Aug 22 08:00:26 KST 2006 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz GenuineIntel GNU/Linux
 >

Comment 6 Andrew Pinski 2006-08-24 01:18:29 UTC
This is most likely a dup of bug 28776 and most likely already fixed.  Can you try a build from today?
Comment 7 happyarch 2006-08-24 05:47:19 UTC
revision 116368 works fine, the bug seems to be fixed.

 > cc -v
Using built-in specs.
Target: i686-pc-linux-gnu
Configured with: ../gcc/configure --prefix=/usr --libexecdir=/usr/lib --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --enable-languages=c,c++,treelang
Thread model: posix
gcc version 4.2.0 20060824 (experimental)
 > uname -a
Linux arch 2.6.18-rc4-git1 #4 PREEMPT Thu Aug 24 14:39:20 KST 2006 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz GenuineIntel GNU/Linux
 >
Comment 8 Andrew Pinski 2006-08-24 10:39:42 UTC

*** This bug has been marked as a duplicate of 28776 ***