Bug 28789 - [4.1 regression] sha512sum miscompiled
Summary: [4.1 regression] sha512sum miscompiled
Status: RESOLVED DUPLICATE of bug 28146
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.1.2
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: wrong-code
Depends on:
Blocks:
 
Reported: 2006-08-21 12:32 UTC by Andreas Schwab
Modified: 2006-08-21 14:27 UTC (History)
4 users (show)

See Also:
Host:
Target: s390-*-*
Build:
Known to work: 3.3.3
Known to fail: 4.1.0 4.1.2
Last reconfirmed:


Attachments
Testcase (2.57 KB, text/plain)
2006-08-21 12:33 UTC, Andreas Schwab
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schwab 2006-08-21 12:32:44 UTC
$ sha512sum < /dev/null
587d521d772a30110a26eda2a81cc763008c8c3d95f5b68abd6a7a66790e0c5a19aec0be2bbabd67680fa6f37ca7ab72b41280e74eeb5f417554c12d3ffeb031  -
Comment 1 Andreas Schwab 2006-08-21 12:33:51 UTC
Created attachment 12109 [details]
Testcase

$ gcc -O2 sha512.c ; ./a.out ; echo $?
1
Comment 2 Andrew Pinski 2006-08-21 14:14:24 UTC
This is most likely a dup of bug 28146 which was not mentioned was a regression and two the patch is inside reload which makes it harder to backport and make sure all the rest of the targets stay working.
Comment 3 Andreas Schwab 2006-08-21 14:27:38 UTC

*** This bug has been marked as a duplicate of 28146 ***