Bug 28730 - [4.0/4.1/4.2 regression] ICE with statement expressions and virtual destructors
Summary: [4.0/4.1/4.2 regression] ICE with statement expressions and virtual destructors
Status: RESOLVED DUPLICATE of bug 27115
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 4.2.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code, monitored
Depends on:
Blocks:
 
Reported: 2006-08-14 22:21 UTC by Volker Reichelt
Modified: 2006-08-14 22:22 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volker Reichelt 2006-08-14 22:21:52 UTC
The following valid code snippet triggers an ICE since GCC 4.0.0:

================================
struct A
{
  virtual ~A();
};

void foo()
{
  A a = ({ A b; b; });
}
================================

bug.cc: In function 'void foo()':
bug.cc:8: internal compiler error: in cp_expr_size, at cp/cp-objcp-common.c:101
Please submit a full bug report, [etc.]

This is related to PR 21440 and PR 27115.
Comment 1 Andrew Pinski 2006-08-14 22:22:41 UTC
This is the same issue as PR 27115.

*** This bug has been marked as a duplicate of 27115 ***