User account creation filtered due to spam.

Bug 28703 - FAIL: gcc.c-torture/execute/pr28651.c execution
Summary: FAIL: gcc.c-torture/execute/pr28651.c execution
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: testsuite (show other bugs)
Version: 4.2.0
: P3 normal
Target Milestone: 4.2.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-12 17:24 UTC by John David Anglin
Modified: 2006-08-16 08:11 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2006-08-12 18:18:05


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John David Anglin 2006-08-12 17:24:42 UTC
FAIL: gcc.c-torture/execute/pr28651.c execution,  -O0
FAIL: gcc.c-torture/execute/pr28651.c execution,  -O1
FAIL: gcc.c-torture/execute/pr28651.c execution,  -O2
FAIL: gcc.c-torture/execute/pr28651.c execution,  -O3 -fomit-frame-pointer
FAIL: gcc.c-torture/execute/pr28651.c execution,  -O3 -g
FAIL: gcc.c-torture/execute/pr28651.c execution,  -Os

This is marked as a testsuite issue because the tests don't actually fail,
at least when run manually.
Comment 1 Andrew Pinski 2006-08-12 18:18:05 UTC
Confirmed, it happens everywhere.
Comment 2 Richard Biener 2006-08-12 19:11:39 UTC
It only happens on the mainline - is dejagnu passing arguments to the testcases?
Comment 3 Richard Biener 2006-08-12 19:20:19 UTC
I cannot reproduce this with

make check-gcc RUNTESTFLAGS="execute.exp=pr28651.c"

ii  dejagnu             1.4.4.cvs20060709-2
ii  expect              5.43.0-7

Janis, any idea?
Comment 4 Andrew Pinski 2006-08-12 19:22:13 UTC
I use dejagnu 1.4.4 release.
Anyways just get rid of the check inside the testcase for argc, and mark the other function as non inliniable.
Comment 5 Richard Biener 2006-08-12 19:59:33 UTC
Sure - that would be the obvious fix if passing arguments is the problem.  But I'd like someone to confirm that first.
Comment 6 Richard Biener 2006-08-14 15:05:46 UTC
Subject: Bug 28703

Author: rguenth
Date: Mon Aug 14 16:05:37 2006
New Revision: 116129

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=116129
Log:
2006-08-14  Richard Guenther  <rguenther@suse.de>
 
	PR testsuite/28703
	* gcc.c-torture/execute/pr28651.c: Do not use argc
	to avoid optimization, instead forbid inlining.

Modified:
    trunk/gcc/testsuite/ChangeLog
    trunk/gcc/testsuite/gcc.c-torture/execute/pr28651.c

Comment 7 Andrew Pinski 2006-08-15 05:56:50 UTC
Fixed.
Comment 8 dave 2006-08-15 23:37:02 UTC
Subject: Re:  FAIL: gcc.c-torture/execute/pr28651.c execution

> Fixed.

It doesn't appear to have been fixed on the 4.1 branch yet.

Dave
Comment 9 Richard Biener 2006-08-16 08:11:37 UTC
Never saw it on the branch.
Comment 10 Janis Johnson 2006-11-13 23:01:27 UTC
Subject: Bug 28703

Author: janis
Date: Mon Nov 13 23:01:09 2006
New Revision: 118782

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=118782
Log:
	Backport from mainline:
	2006-08-14  Richard Guenther  <rguenther@suse.de>

	PR testsuite/28703
	* gcc.c-torture/execute/pr28651.c: Do not use argc
	to avoid optimization, instead forbid inlining.

Modified:
    branches/gcc-4_1-branch/gcc/testsuite/ChangeLog
    branches/gcc-4_1-branch/gcc/testsuite/gcc.c-torture/execute/pr28651.c

Comment 11 Richard Biener 2007-01-25 19:05:30 UTC
Subject: Bug 28703

Author: rguenth
Date: Thu Jan 25 19:05:19 2007
New Revision: 121181

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=121181
Log:
2007-01-25  Richard Guenther  <rguenther@suse.de>

	Backport from mainline:
	2006-08-11  Richard Guenther  <rguenther@suse.de>

	PR middle-end/28651
	* simplify-rtx.c (simplify_const_relational_operation):
	Simplify A CMP B to A - B CMP 0 only for EQ and NE comparison
	codes.

	* gcc.c-torture/execute/pr28651.c: New testcase.

	2006-08-14  Richard Guenther  <rguenther@suse.de>

	PR testsuite/28703
	* gcc.c-torture/execute/pr28651.c: Do not use argc
	to avoid optimization, instead forbid inlining.

Added:
    branches/gcc-4_0-branch/gcc/testsuite/gcc.c-torture/execute/pr28651.c
      - copied, changed from r116079, trunk/gcc/testsuite/gcc.c-torture/execute/pr28651.c
Modified:
    branches/gcc-4_0-branch/gcc/ChangeLog
    branches/gcc-4_0-branch/gcc/simplify-rtx.c
    branches/gcc-4_0-branch/gcc/testsuite/ChangeLog