GCC Bugzilla has been upgraded from version 4.4.9 to 5.0rc3. If you see any problem, please report it to bug 64968.
Bug 28695 - Problem compiling Gcc 4.1.1 on a 64 bit linux redhat kernel
Summary: Problem compiling Gcc 4.1.1 on a 64 bit linux redhat kernel
Status: RESOLVED INVALID
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 4.1.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-11 11:47 UTC by f98faka
Modified: 2006-11-20 05:51 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description f98faka 2006-08-11 11:47:29 UTC
I'm running linux redhat, kernel 2.6.9-34.0.1.ELsmp, duel processor AMD Opteron 250. It's on a cluster where I only have write-rights in my user library and thus need to compile my own version of gcc. 
I downloaded gcc from 

ftp://ftp.mpi-sb.mpg.de/pub/gnu/mirror/gcc.gnu.org/pub/gcc/releases/gcc-4.1.1

I unpacked and altered configure file value: ac_default_prefix to the directory where I wanted it to be (in this case the same as the one where sources were). I also tried default value for ac_default_prefix, but it produces the same error. Running ./configure worked ok, then when i did "make" I got:


/tmp/cc9Ery9d.s: Assembler messages:
/tmp/cc9Ery9d.s:34: Error: suffix or operands invalid for `push'
/tmp/cc9Ery9d.s:36: Error: suffix or operands invalid for `push'
/tmp/cc9Ery9d.s:38: Internal error, aborting at ../../gas/config/tc-i386.c line 3501 in output_imm
Please report this bug.

I can't do a -save-temp since I only run 'make'. It feels like I haven't given you much information, but I'm not sure what else to give you.
Comment 1 Andrew Pinski 2006-08-16 05:36:16 UTC
Can you first configure in a different object directory?
Second can you try using "make bootstrap" instead of make?
Third can you paste the command that failed?
Comment 2 f98faka 2006-08-16 09:13:02 UTC
I tried changing the ax_default_prefix directory, but it didn't help. I tried using make bootstrap instead of make and got

libcpp.a(charset.o)(.text+0x2e): In function `convert_utf8_utf16':
: undefined reference to `one_utf8_to_utf16'
libcpp.a(charset.o)(.text+0x1bd): In function `convert_utf8_utf32':
: undefined reference to `one_utf8_to_utf32'
libcpp.a(charset.o)(.text+0x1f9): In function `convert_utf16_utf8':
: undefined reference to `one_utf16_to_utf8'
libcpp.a(charset.o)(.text+0x235): In function `convert_utf32_utf8':
: undefined reference to `one_utf32_to_utf8'
collect2: ld returned 1 exit status
make[2]: *** [makedepend] Error 1
make[2]: Leaving directory `/chalmers/users/f98faka/OpenFOAM/linuxAMD64/gcc-4.1.1/host-x86_64-unknown-linux-gnu/libcpp'
make[1]: *** [all-libcpp] Error 2
make[1]: Leaving directory `/chalmers/users/f98faka/OpenFOAM/linuxAMD64/gcc-4.1.1'
make: *** [all] Error 2

The comand that failed before was make, but unfortunately I cannot reproduce the error now, I just get the error previously pasted. Sorry if I've wasted your time. 
Comment 3 Ian Cowan 2006-08-21 13:34:06 UTC
I also have the same problem with "gmake bootstrap", with my opteron based RHEL systems (kernels 2.4.21-20.ELsmp and 2.6.9-11.ELsmp).
Comment 4 Andrew Pinski 2006-11-20 05:51:29 UTC
(In reply to comment #2)
> I tried changing the ax_default_prefix directory, but it didn't help. I tried
> using make bootstrap instead of make and got

That issue is a bug in the kernel headers and is hard to fix in GCC.

Anyways I have been able to build 4.1.1 on a x86_64 machine just fine.