User account creation filtered due to spam.

Bug 28273 - gcc fails to compile with dwarf2 support
Summary: gcc fails to compile with dwarf2 support
Status: RESOLVED DUPLICATE of bug 26504
Alias: None
Product: gcc
Classification: Unclassified
Component: debug (show other bugs)
Version: 4.1.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-05 16:46 UTC by Brian Sidebotham
Modified: 2006-07-05 17:31 UTC (History)
3 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: avr
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Sidebotham 2006-07-05 16:46:41 UTC
gcc 4.1.1 fails to make with the following configure command:

from inside a custom directory avrobj created in gcc-4.1.1:
../configure --target=avr --prefix=/usr/local/avr --enable-languages=c --with-elf --with-dwarf2 --with-stabs --disable-libssp --disable-nls

message from make failure is:
../../gcc/libgcc2.c:1499: internal compiler error: in compute_frane_pointer_to_cfa_displacement, at dwarf2out.c:10446

binutils 2.17 already installed for target=avr

make does work fine with a configure command that does not include --with-dwarf2
Comment 1 Andrew Pinski 2006-07-05 17:31:53 UTC

*** This bug has been marked as a duplicate of 26504 ***