Bug 27807 - [4.1/4.2 regression] ICE on invalid initializer
[4.1/4.2 regression] ICE on invalid initializer
Status: RESOLVED FIXED
Product: gcc
Classification: Unclassified
Component: c++
4.2.0
: P2 normal
: 4.1.2
Assigned To: Mark Mitchell
: ice-on-invalid-code, monitored
: 28787 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-29 21:17 UTC by Volker Reichelt
Modified: 2006-08-21 10:48 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2006-05-31 02:29:33


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volker Reichelt 2006-05-29 21:17:45 UTC
The following invalid code snippet causes an ICE since GCC 4.1.0:

=========================
int i = (int()){0};
=========================

bug.cc:1: internal compiler error: in digest_init, at cp/typeck2.c:718
Please submit a full bug report, [etc.]

This is probably fallout from PR23172.
Comment 1 Wolfgang Bangerth 2006-05-31 02:29:33 UTC
Confirmed
Comment 2 Mark Mitchell 2006-06-05 02:46:52 UTC
Subject: Bug 27807

Author: mmitchel
Date: Mon Jun  5 02:46:38 2006
New Revision: 114382

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=114382
Log:
	PR c++/27819
	* decl.c (cp_finish_decl): Process initializers for static data
	members with non-dependent initializers, even in templates.
	PR c++/27722
	* decl.c (maybe_deduce_size_from_array_init): If the declaration
	is erroneous, give it an erroneous type.
	(layout_var_decl): If the type is erroneous, give up.
	(check_initializer): Likewise.
	PR c++/27807
	* cp-tree.h (TYPE_OBJ_P): New macro.
	(TYPE_PTROB_P): Use it.
	(TYPE_REF_OBJ_P): Likewise.
	* semantics.c (finish_compound_literal): Do not permit compound
	literals of non-object types.
	PR c++/27806
	* typeck.c (original_type): Robustify.
	PR c++/27819
	* g++.dg/template/static25.C: New test.
	PR c++/27722
	* g++.dg/init/array21.C: New test.
	PR c++/27807
	* g++.dg/ext/complit7.C: New test.
	
	PR c++/27806
	* g++.dg/parse/ptrmem5.C: New test.

Added:
    trunk/gcc/testsuite/g++.dg/ext/complit7.C
    trunk/gcc/testsuite/g++.dg/init/array21.C
    trunk/gcc/testsuite/g++.dg/parse/ptrmem5.C
    trunk/gcc/testsuite/g++.dg/template/static25.C
Modified:
    trunk/gcc/cp/ChangeLog
    trunk/gcc/cp/cp-tree.h
    trunk/gcc/cp/decl.c
    trunk/gcc/cp/semantics.c
    trunk/gcc/cp/typeck.c
    trunk/gcc/testsuite/ChangeLog

Comment 3 Mark Mitchell 2006-06-05 02:52:48 UTC
Subject: Bug 27807

Author: mmitchel
Date: Mon Jun  5 02:52:37 2006
New Revision: 114383

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=114383
Log:
	PR c++/27819
	* decl.c (cp_finish_decl): Process initializers for static data
	members with non-dependent initializers, even in templates.
	PR c++/27722
	* decl.c (maybe_deduce_size_from_array_init): If the declaration
	is erroneous, give it an erroneous type.
	(layout_var_decl): If the type is erroneous, give up.
	(check_initializer): Likewise.
	PR c++/27807
	* cp-tree.h (TYPE_OBJ_P): New macro.
	(TYPE_PTROB_P): Use it.
	(TYPE_REF_OBJ_P): Likewise.
	* semantics.c (finish_compound_literal): Do not permit compound
	literals of non-object types.
	PR c++/27806
	* typeck.c (original_type): Robustify.
	PR c++/27819
	* g++.dg/template/static25.C: New test.
	PR c++/27722
	* g++.dg/init/array21.C: New test.
	PR c++/27807
	* g++.dg/ext/complit7.C: New test.
	
	PR c++/27806
	* g++.dg/parse/ptrmem5.C: New test.

Added:
    branches/gcc-4_1-branch/gcc/testsuite/g++.dg/ext/complit7.C
    branches/gcc-4_1-branch/gcc/testsuite/g++.dg/init/array21.C
    branches/gcc-4_1-branch/gcc/testsuite/g++.dg/parse/ptrmem5.C
    branches/gcc-4_1-branch/gcc/testsuite/g++.dg/template/static25.C
Modified:
    branches/gcc-4_1-branch/gcc/cp/ChangeLog
    branches/gcc-4_1-branch/gcc/cp/cp-tree.h
    branches/gcc-4_1-branch/gcc/cp/decl.c
    branches/gcc-4_1-branch/gcc/cp/semantics.c
    branches/gcc-4_1-branch/gcc/cp/typeck.c
    branches/gcc-4_1-branch/gcc/testsuite/ChangeLog

Comment 4 Mark Mitchell 2006-06-05 02:54:29 UTC
Fixed in 4.1.2, 4.2.0.
Comment 5 Richard Biener 2006-08-21 10:48:09 UTC
*** Bug 28787 has been marked as a duplicate of this bug. ***