Bug 27179 - libgomp bootstrap failure: unhandled reloc type 67
Summary: libgomp bootstrap failure: unhandled reloc type 67
Status: RESOLVED DUPLICATE of bug 25865
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.2.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on: 25865
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-16 16:37 UTC by Gerald Pfeifer
Modified: 2006-04-20 23:47 UTC (History)
6 users (show)

See Also:
Host: sparc64-portbld-freebsd6.1
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2006-04-16 16:37:36 UTC
GCC fails to bootstrap on sparc64-*-freebsd6.1 when building libgomp:

/work/a/ports/lang/gcc42/work/build/./gcc/xgcc
-B/work/a/ports/lang/gcc42/work/build/./gcc/
-B/usr/local/sparc64-portbld-freebsd6.1/bin/
-B/usr/local/sparc64-portbld-freebsd6.1/lib/ -isystem
/usr/local/sparc64-portbld-freebsd6.1/include -isystem
/usr/local/sparc64-portbld-freebsd6.1/sys-include -shared  .libs/alloc.o
.libs/barrier.o .libs/critical.o .libs/env.o .libs/error.o .libs/iter.o
.libs/loop.o .libs/ordered.o .libs/parallel.o .libs/sections.o
.libs/single.o .libs/team.o .libs/work.o .libs/lock.o .libs/mutex.o
.libs/proc.o .libs/sem.o .libs/bar.o .libs/time.o .libs/fortran.o   -pthread
-Wl,-z -Wl,nodlopen -Wl,-O1 -Wl,--version-script
-Wl,../.././..//gcc-4.2-20060408/libgomp/libgomp.map -Wl,-soname
-Wl,libgomp.so.1 -o .libs/libgomp.so.1
/usr/bin/ld: .libs/barrier.o: check_relocs: unhandled reloc type 67
.libs/barrier.o: could not read symbols: File format not recognized
collect2: ld returned 1 exit status
gmake[4]: *** [libgomp.la] Error 1
gmake[4]: Leaving directory
`/work/a/ports/lang/gcc42/work/build/sparc64-portbld-freebsd6.1/libgomp'
Comment 1 Andrew Pinski 2006-04-16 17:59:36 UTC
IIRC this is because libgomp is decting your target has TLS support when in fact it does not.
Comment 2 Andrew Pinski 2006-04-19 00:49:29 UTC
Does Sparc-FreeBSD have working TLS support?
Comment 3 Gerald Pfeifer 2006-04-20 23:46:01 UTC
(In reply to comment #2)
> Does Sparc-FreeBSD have working TLS support?

According to FreeBSD developers I asked, it does not, yet (probably due
to missing binutils support).
Comment 4 Andrew Pinski 2006-04-20 23:47:36 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > Does Sparc-FreeBSD have working TLS support?
> According to FreeBSD developers I asked, it does not, yet (probably due
> to missing binutils support).

That means this is a dup of bug 25865.  Yes that was filed about netbsd but it also effects other targets.

*** This bug has been marked as a duplicate of 25865 ***