Bug 27049 - should link to xdg mime type database
Summary: should link to xdg mime type database
Status: RESOLVED FIXED
Alias: None
Product: classpath
Classification: Unclassified
Component: classpath (show other bugs)
Version: 0.90
: P3 enhancement
Target Milestone: 0.92
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-05 19:38 UTC by Tom Tromey
Modified: 2006-09-12 16:44 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2006-04-05 20:03:55


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Tromey 2006-04-05 19:38:24 UTC
Mark says:

Note that there is a standard on freedesktop.org:
http://freedesktop.org/wiki/Standards_2fshared_2dmime_2dinfo_2dspec
plus an associated mime-database plus some software that is shared
between different GNU/Linux dekstop projects like Gnome, KDE:
http://freedesktop.org/wiki/Software_2fshared_2dmime_2dinfo
which should be included in the major GNU/Linux and BSD distributions.
Comment 1 Tom Tromey 2006-04-05 20:03:55 UTC
Additionally, Chris Burdess says:

It might be worth considering merging or incorporating JAF to do this.
Comment 2 Tom Tromey 2006-05-24 18:44:21 UTC
The freedesktop reference implementation isn't actually packaged.
I believe users are intended to bundle it themselves.  Perhaps
we could use it via gnome-vfs somehow.

I'm testing a simple alternate approach based on libmagic
(Sven's suggestion).
Comment 3 Tom Tromey 2006-09-12 16:44:57 UTC
I checked in a libmagic-based implementation a while back.