Bug 26946 - JInternalFrame: dragging around should work when clicking on the title
Summary: JInternalFrame: dragging around should work when clicking on the title
Status: RESOLVED WORKSFORME
Alias: None
Product: classpath
Classification: Unclassified
Component: swing (show other bugs)
Version: 0.90
: P3 normal
Target Milestone: 0.92
Assignee: Roman Kennke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-30 17:25 UTC by Robert Schuster
Modified: 2006-05-15 07:45 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2006-05-03 20:45:57


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Schuster 2006-03-30 17:25:01 UTC
Currently a JInternalFrame can only be moved around by clicking and holding on the free space beside the frame's title. On the RI that works also on the title.

The current behavior is problematic when the frame is so small that no free space is left besides the title text because you cannot move it around then.
Comment 1 Audrius Meškauskas 2006-05-04 09:47:35 UTC
Protege needs this, also
Comment 2 Robert Schuster 2006-05-15 07:45:40 UTC
This works in CVS HEAD.