User account creation filtered due to spam.

Bug 26849 - gnat_to_gnu error when using Short_Integer
Summary: gnat_to_gnu error when using Short_Integer
Status: RESOLVED DUPLICATE of bug 10768
Alias: None
Product: gcc
Classification: Unclassified
Component: ada (show other bugs)
Version: 4.1.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-24 15:47 UTC by Rolf Ebert
Modified: 2006-04-26 20:40 UTC (History)
6 users (show)

See Also:
Host:
Target: avr
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rolf Ebert 2006-03-24 15:47:25 UTC
This simple package causes a GNAT bug box

package Short is
   bug : Short_Integer;
end Short;

+===========================GNAT BUG DETECTED==============================+
| 4.1.0 20060116 (prerelease) AVR-Ada snapshot (avr-unknown-none) GCC error:|
| in gnat_to_gnu, at ada/trans.c:2588                                      |
| No source file position information available                            |


A somewhat related case is the derivation of Integer types:

package AVR_B2 is
   type Toto is new Integer;
end AVR_B2;
Comment 1 Andrew Pinski 2006-04-26 20:40:58 UTC

*** This bug has been marked as a duplicate of 10768 ***