Bug 26603 - ICE on invalid using non static inner class as base class outside the class
Summary: ICE on invalid using non static inner class as base class outside the class
Status: RESOLVED DUPLICATE of bug 18130
Alias: None
Product: gcc
Classification: Unclassified
Component: java (show other bugs)
Version: unknown
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-invalid-code
Depends on:
Blocks:
 
Reported: 2006-03-08 12:03 UTC by aNDRZEJ sALWICKI
Modified: 2006-03-08 13:00 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail: 3.0.4 3.2.3 3.4.0 4.0.0 4.1.0 4.2.0
Last reconfirmed: 2006-03-08 12:59:57


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description aNDRZEJ sALWICKI 2006-03-08 12:03:33 UTC
when compiling 

class A{
    class B{}
}

class C extends A.B{}

with 
gcj -S 
compiler crashes

     author of report
                     Marek Warpechowski  warp@mimuw.edu.pl
Comment 1 Andrew Pinski 2006-03-08 12:59:57 UTC
This is invalid code as you cannot use A.B outside of A as it is not a static inner class.

Confirmed, not a regression.
Comment 2 Andrew Pinski 2006-03-08 13:00:54 UTC
This is a dup of bug 18130.

*** This bug has been marked as a duplicate of 18130 ***