User account creation filtered due to spam.

Bug 26221 - regex lookbehind not supported?
Summary: regex lookbehind not supported?
Status: RESOLVED DUPLICATE of bug 25812
Alias: None
Product: classpath
Classification: Unclassified
Component: classpath (show other bugs)
Version: 0.20
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-11 10:46 UTC by Andy Seaborne
Modified: 2006-02-12 22:23 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Seaborne 2006-02-11 10:46:21 UTC
GNU classpath from ikvm 0.24.0.1

A regular expression with a zero-width positive lookbehind does not compile:

        Pattern x = Pattern.compile("(?<=X)") ;

It seems that lookbehind isn't supported by the regex implementation.

Similarly, zero-width negative lookbehind "(?<!X)"

    Andy
Comment 1 Ito Kazumitsu 2006-02-12 22:23:13 UTC
This bug is the same as Bug #25812, and it has been fixed.  As far as I know, IKVM uses a precompiled GNU Classpath library. But this fix was done only recently, and it is not reflected in IKVM.  

*** This bug has been marked as a duplicate of 25812 ***