User account creation filtered due to spam.

Bug 26072 - missed diagnostic about initialization with an uninitialized variable.
Summary: missed diagnostic about initialization with an uninitialized variable.
Status: RESOLVED DUPLICATE of bug 19808
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 4.1.0
: P3 enhancement
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-02 09:20 UTC by Pawel Sikora
Modified: 2006-02-02 12:58 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pawel Sikora 2006-02-02 09:20:39 UTC
struct A {
    A(int v) : v_(v_) { }
               ^^^^^^ I would love to see a warning here.
    int v_;
};
Comment 1 Andrew Pinski 2006-02-02 12:58:41 UTC
This is an exact dup of bug 19808.

*** This bug has been marked as a duplicate of 19808 ***