User account creation filtered due to spam.

Bug 25707 - support for Fortran 2003 USE statements, INTRINSIC and NONINTRINSIC
Summary: support for Fortran 2003 USE statements, INTRINSIC and NONINTRINSIC
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.2.0
: P3 enhancement
Target Milestone: 4.3.0
Assignee: Francois-Xavier Coudert
URL: http://gcc.gnu.org/ml/gcc-patches/200...
Keywords:
: 29643 (view as bug list)
Depends on:
Blocks: 20585 22547
  Show dependency treegraph
 
Reported: 2006-01-07 05:04 UTC by Andrew Pinski
Modified: 2006-11-17 11:16 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2006-10-21 17:30:35


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Pinski 2006-01-07 05:04:00 UTC
http://publib.boulder.ibm.com/infocenter/comphelp/v8v101/index.jsp?topic=/com.ibm.xlf101a.doc/xlflr/use.htm
statements like as valid:
use INTRINSIC, ISO_FORTRAN_ENV
end
Comment 1 Janne Blomqvist 2006-01-07 17:58:22 UTC
Confirmed. 

Incidentally, you can find the final draft of F2003 (which differs very little from the published standard) at http://www.j3-fortran.org/doc/year/04/04-007.pdf
Comment 2 Janne Blomqvist 2006-01-07 18:09:01 UTC
Actually, you got the syntax slightly wrong (sorry for not noticing it right away).

The standard (and from my reading of the ibm docs it seems that they agree with the standard) specifices the use statement as

use [[, module-nature] ::] module-name [etc...]

where module-nature is either intrinsic or non_intrinsic. That is, if module-nature is specified the ',' and '::' are mandatory, so the statement in comment #1 must be of the form

use, intrinsic :: iso_fortran_env
Comment 3 Francois-Xavier Coudert 2006-10-21 17:30:35 UTC
It's an enhancement (and actually, it's being worked on).
Comment 4 Francois-Xavier Coudert 2006-10-30 12:16:00 UTC
*** Bug 29643 has been marked as a duplicate of this bug. ***
Comment 5 Paul Thomas 2006-11-07 21:38:55 UTC
FX,

I think that the keywords patch and rejects valid are both incorrect for this PR - it's an enhancement, plain and simple.

Paul
Comment 6 Francois-Xavier Coudert 2006-11-17 11:16:16 UTC
Fixed on mainline (rev. 118930)