Bug 25424 - ICE in f77 with -finit-local-zero
Summary: ICE in f77 with -finit-local-zero
Status: RESOLVED DUPLICATE of bug 18913
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 3.4.5
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-15 08:04 UTC by Mark Loeser
Modified: 2005-12-15 08:29 UTC (History)
2 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail: 3.3.6 3.4.4 3.4.5
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Loeser 2005-12-15 08:04:59 UTC
f77 -finit-local-zero test.f 
test.f: In program `test':
In file included from test.f:0:
test.f:2: internal compiler error: Segmentation fault

Test case:

      PROGRAM TEST
      COMPLEX CZERO(1)
      END

>=gcc-4 seems to have this option removed now
Comment 1 Toon Moene 2005-12-15 08:29:22 UTC

*** This bug has been marked as a duplicate of 18913 ***