Bug 25166 - [4.2 Regression] FAIL: gcc.c-torture/execute/conversion.c compilation
Summary: [4.2 Regression] FAIL: gcc.c-torture/execute/conversion.c compilation
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.2.0
: P3 normal
Target Milestone: 4.2.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-29 23:51 UTC by John David Anglin
Modified: 2005-12-05 03:44 UTC (History)
1 user (show)

See Also:
Host: hppa2.0w-hp-hpux11.11
Target: hppa2.0w-hp-hpux11.11
Build: hppa2.0w-hp-hpux11.11
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John David Anglin 2005-11-29 23:51:25 UTC
Executing on host: /mnt/gnu/gcc-3.3/objdir/gcc/xgcc -B/mnt/gnu/gcc-3.3/objdir/gc
c/ /mnt/gnu/gcc-3.3/gcc/gcc/testsuite/gcc.c-torture/execute/conversion.c  -w  -O
0  -fno-show-column  -lm   -o /mnt/gnu/gcc-3.3/objdir/gcc/testsuite/conversion.x
0    (timeout = 300)
/usr/bin/ld: Unsatisfied symbols:
   __floatunsitf (first referenced in /var/tmp//ccCj8jFh.o) (code)
collect2: ld returned 1 exit status
compiler exited with status 1
output is:
/usr/bin/ld: Unsatisfied symbols:
   __floatunsitf (first referenced in /var/tmp//ccCj8jFh.o) (code)
collect2: ld returned 1 exit status

FAIL: gcc.c-torture/execute/conversion.c compilation,  -O0
Comment 1 John David Anglin 2005-11-29 23:58:41 UTC
The same error also causes the failure of gcc.dg/torture/fp-int-convert-long-double.c:
Executing on host: /mnt/gnu/gcc-3.3/objdir/gcc/xgcc -B/mnt/gnu/gcc-3.3/objdir/gc
c/ /mnt/gnu/gcc-3.3/gcc/gcc/testsuite/gcc.dg/torture/fp-int-convert-long-double.
c   -O0   -fno-show-column  -lm   -o ./fp-int-convert-long-double.exe    (timeou
t = 300)
/usr/bin/ld: Unsatisfied symbols:
   __floatunsitf (first referenced in /var/tmp//ccztHixV.o) (code)
collect2: ld returned 1 exit status
compiler exited with status 1
output is:
/usr/bin/ld: Unsatisfied symbols:
   __floatunsitf (first referenced in /var/tmp//ccztHixV.o) (code)
collect2: ld returned 1 exit status

FAIL: gcc.dg/torture/fp-int-convert-long-double.c  -O0  (test for excess errors)

Comment 2 John David Anglin 2005-11-30 00:00:06 UTC
And gcc.dg/torture/fp-int-convert-timode.c.
Comment 3 Andrew Pinski 2005-11-30 00:00:59 UTC
This is a regression.
Comment 4 joseph@codesourcery.com 2005-11-30 00:35:16 UTC
Subject: Re:   New: FAIL: gcc.c-torture/execute/conversion.c
 compilation

As explained in bug 24998, I can't test on PA at present but the fix is 
probably similar to that for IA64.

Comment 5 dave 2005-11-30 03:51:07 UTC
Subject: Re:  [4.2 Regression] FAIL: gcc.c-torture/execute/conversion.c compilation

> As explained in bug 24998, I can't test on PA at present but the fix is 
> probably similar to that for IA64.

I'm testing a fix for the current reload problems on the PA.  This should
be installed tomorrow morning if all goes well.

Would you test your IA64 fix on the PA?  It looks like the same fix should
work.  Preapproved assuming testing is successful.

Dave
Comment 6 joseph@codesourcery.com 2005-11-30 04:14:05 UTC
Subject: Re:  [4.2 Regression] FAIL: gcc.c-torture/execute/conversion.c
 compilation

On Wed, 30 Nov 2005, dave at hiauly1 dot hia dot nrc dot ca wrote:

> I'm testing a fix for the current reload problems on the PA.  This should
> be installed tomorrow morning if all goes well.
> 
> Would you test your IA64 fix on the PA?  It looks like the same fix should
> work.  Preapproved assuming testing is successful.

I can't test on PA because of a non-working PA system, not because of any 
breakage that may have occurred on PA after the 18th.

Comment 7 John David Anglin 2005-12-05 03:23:41 UTC
Subject: Bug 25166

Author: danglin
Date: Mon Dec  5 03:23:37 2005
New Revision: 108039

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=108039
Log:
	PR target/25166
	* pa/pa.c (pa_hpux_init_libfuncs): Add _U_Qfcnvxf_usgl_to_quad and
	_U_Qfcnvxf_udbl_to_quad to set of initialized libfuncs.
	* pa/quadlib.c (_U_Qfcnvxf_usgl_to_quad, _U_Qfcnvxf_udbl_to_quad): New
	functions.


Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/config/pa/pa.c
    trunk/gcc/config/pa/quadlib.c

Comment 8 John David Anglin 2005-12-05 03:44:15 UTC
Fixed by patch.