Bug 25146 - ICE on error diagnostics
Summary: ICE on error diagnostics
Status: RESOLVED DUPLICATE of bug 24958
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.2.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks: 19292
  Show dependency treegraph
 
Reported: 2005-11-28 19:09 UTC by Bernhard Fischer
Modified: 2006-01-15 19:28 UTC (History)
3 users (show)

See Also:
Host: i686-linux-gnu
Target: i686-linux-gnu
Build: i686-linux-gnu
Known to work:
Known to fail:
Last reconfirmed: 2005-11-30 22:06:06


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Fischer 2005-11-28 19:09:15 UTC
$ cat invalid_nullify.F 
       program ice_on_error_diagnostics
       implicit none
       TYPE (nonexisting_type1) t1 !, TARGET :: t1
       nullify(t1%something)
       end program
$ gfortran-4.0 invalid_nullify.F 
 In file invalid_nullify.F:3

       TYPE (nonexisting_type1) t1 !, TARGET :: t1                      
                              1
Error: Derived type 'nonexisting_type1' at (1) is being used before it is defined
*** glibc detected *** free(): invalid pointer: 0x08510b00 ***
/tmp/ccXyK2zB.f:0: internal compiler error: Aborted
$ gfortran-4.0 --version
GNU Fortran 95 (GCC 4.0.2 (Debian 4.0.2-2))

I get the same ICE with gfortran-4.{1,2}

g77-3.4.5 does print the error diagnostics proper, so please set 19292 to depend on this one.
Comment 1 eedelman 2005-11-30 22:06:05 UTC
Confirmed.
Comment 2 Andrew Pinski 2006-01-15 19:28:46 UTC

*** This bug has been marked as a duplicate of 24958 ***