Bug 24995 - [4.1/4.2 Regression] gcc.dg/vect/vect-10.c fails for -march=athlon
Summary: [4.1/4.2 Regression] gcc.dg/vect/vect-10.c fails for -march=athlon
Status: RESOLVED DUPLICATE of bug 24982
Alias: None
Product: gcc
Classification: Unclassified
Component: rtl-optimization (show other bugs)
Version: 4.1.0
: P3 normal
Target Milestone: 4.1.0
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2005-11-23 03:58 UTC by Andrew Pinski
Modified: 2005-11-24 10:24 UTC (History)
3 users (show)

See Also:
Host:
Target: i686-pc-linux-gnu
Build:
Known to work:
Known to fail:
Last reconfirmed: 2005-11-23 03:58:41


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Pinski 2005-11-23 03:58:14 UTC
/home/pinskia/src/checkin/trunk/gcc/testsuite/gcc.dg/vect/vect-10.c: In function 'foo':^M
/home/pinskia/src/checkin/trunk/gcc/testsuite/gcc.dg/vect/vect-10.c:24: internal compiler error: in refers_to_regno_for_reload_p, at reload.c:6281^M
Please submit a full bug report,^M
with preprocessed source if appropriate.^M
See <URL:http://gcc.gnu.org/bugs.html> for instructions.^M

FAIL: gcc.dg/vect/vect-10.c (test for excess errors)
Comment 1 Andrew Pinski 2005-11-23 03:58:41 UTC
Independently found in:
http://gcc.gnu.org/ml/gcc-testresults/2005-11/msg01074.html
Comment 2 Uroš Bizjak 2005-11-24 10:19:59 UTC
This also fails for i686-pc-linux-gnu with '-march=athlon'.

The patch at http://gcc.gnu.org/ml/gcc-patches/2005-11/msg01648.html fixes i86_64-pc-linux-gnu failure in original report and -march=athlon failure.

FWIW, -fomit-frame-pointer also fixes these failures.

This PR is a duplicate of 24982.

*** This bug has been marked as a duplicate of 24982 ***