Bug 24778 - [4.1 Regression] Assembler errors during bootstrap
Summary: [4.1 Regression] Assembler errors during bootstrap
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.1.0
: P3 blocker
Target Milestone: 4.1.0
Assignee: Alexandre Oliva
URL:
Keywords: assemble-failure, build
Depends on:
Blocks:
 
Reported: 2005-11-10 17:14 UTC by Erik Schnetter
Modified: 2005-11-10 20:04 UTC (History)
2 users (show)

See Also:
Host: powerpc-apple-darwin8.3.0
Target: powerpc-apple-darwin8.3.0
Build: powerpc-apple-darwin8.3.0
Known to work:
Known to fail:
Last reconfirmed: 2005-11-10 18:11:47


Attachments
Complete error message (35.94 KB, application/octet-stream)
2005-11-10 17:22 UTC, Erik Schnetter
Details
Failing assembler output (220.83 KB, application/octet-stream)
2005-11-10 17:24 UTC, Erik Schnetter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Schnetter 2005-11-10 17:14:00 UTC
I checked out gcc from svn; I have version

$ svn info
Path: .
URL: svn://gcc.gnu.org/svn/gcc/trunk
Repository UUID: 138bc75d-0d04-0410-961f-82ee72b054a4
Revision: 106735
Node Kind: directory
Schedule: normal
Last Changed Author: jakub
Last Changed Rev: 106735
Last Changed Date: 2005-11-10 07:14:05 -0600 (Thu, 10 Nov 2005)
Properties Last Updated: 2005-10-30 14:22:49 -0600 (Sun, 30 Oct 2005)

I configured with

CFLAGS='-g -O2 -mlongcall' CXXFLAGS='-g -O2 -mlongcall' /Users/eschnett/src/gcc/configure --prefix=/Users/eschnett/gcc --with-mpfr=/Users/eschnett --disable-multilib --enable-languages=c,c++,fortran,java,objc,treelang

and then built with

make bootstrap

This aborts with the error message

stage1/xgcc -Bstage1/ -B/Users/eschnett/gcc/powerpc-apple-darwin8.3.0/bin/   -g -O2 -mdynamic-no-pic -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long -Wno-variadic-macros -Wold-style-definition -Wmissing-format-attribute -Werror -fno-common   -DHAVE_CONFIG_H -I. -I. -I/Users/eschnett/src/gcc/gcc -I/Users/eschnett/src/gcc/gcc/. -I/Users/eschnett/src/gcc/gcc/../include -I./../intl -I/Users/eschnett/src/gcc/gcc/../libcpp/include -I/Users/eschnett/include    -c insn-recog.c \
  -o insn-recog.o
/var/tmp//ccGgfnke.s:101631:Fixup of 4294730560 too large for field width of 16 bits
/var/tmp//ccGgfnke.s:101629:Fixup of 4294730568 too large for field width of 16 bits
/var/tmp//ccGgfnke.s:99974:Fixup of 4294734684 too large for field width of 16 bits
/var/tmp//ccGgfnke.s:99964:Fixup of 4294734708 too large for field width of 16 bits
/var/tmp//ccGgfnke.s:99348:Fixup of 4294736180 too large for field width of 16 bits
/var/tmp//ccGgfnke.s:99345:Fixup of 4294736192 too large for field width of 16 bits
/var/tmp//ccGgfnke.s:99035:Fixup of 4294736896 too large for field width of 16 bits
/var/tmp//ccGgfnke.s:99033:Fixup of 4294736904 too large for field width of 16 bits
/var/tmp//ccGgfnke.s:99024:Fixup of 4294736928 too large for field width of 16 bits

The error message continues for about 8000 more lines.
Comment 1 Erik Schnetter 2005-11-10 17:22:58 UTC
Created attachment 10203 [details]
Complete error message
Comment 2 Erik Schnetter 2005-11-10 17:24:19 UTC
Created attachment 10204 [details]
Failing assembler output

This is from a different invokation of the compiler, i.e., the auto-generated file name is different from the one in the error message.
Comment 3 Andrew Pinski 2005-11-10 17:32:42 UTC
Something is really wrong:
        beq- cr7,_L13070


There should be no underscore there.

Some get it correct:
        b L12781

What gcc are you starting with?
What happens if you remove -mlongcall from the CFLAGS?
Comment 4 Andrew Pinski 2005-11-10 18:03:05 UTC
Caused by:
http://gcc.gnu.org/viewcvs?view=rev&rev=106703

Comment 5 Alexandre Oliva 2005-11-10 18:11:47 UTC
Mine.  I'll try to get the failure with a cross compiler.
Comment 6 Alexandre Oliva 2005-11-10 19:54:11 UTC
Subject: Bug 24778

Author: aoliva
Date: Thu Nov 10 19:54:06 2005
New Revision: 106749

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=106749
Log:
PR target/24778
* varasm.c (assemble_name): Recompute name only for transparent
aliases.

Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/varasm.c

Comment 7 Alexandre Oliva 2005-11-10 20:04:52 UTC
Fixed