Bug 24691 - attribute aligned is silently ignored or program is miscompiled
Summary: attribute aligned is silently ignored or program is miscompiled
Status: RESOLVED DUPLICATE of bug 16660
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: unknown
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-06 06:06 UTC by Chris Lattner
Modified: 2005-11-06 06:11 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Lattner 2005-11-06 06:06:50 UTC
This program shows a bug: either attribute align is being accepted when it shouldn't be, or it is being accepted but not doing it's job:

int foo() {
  int __attribute__((aligned(1024))) X;
  printf("%d\n", (int)&X & 1023);
}
int main() {
  foo();
}

On my machine, this prints "752".

-Chris
Comment 1 Andrew Pinski 2005-11-06 06:11:08 UTC
Local variables is the only issue.

*** This bug has been marked as a duplicate of 16660 ***