Bug 24606 - ICE on template function which gets an template agrument as a function with a default argument
Summary: ICE on template function which gets an template agrument as a function with a...
Status: RESOLVED DUPLICATE of bug 24602
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 4.1.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-invalid-code, monitored
Depends on:
Blocks: 24602
  Show dependency treegraph
 
Reported: 2005-11-01 02:49 UTC by Andrew Pinski
Modified: 2007-07-23 22:08 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail: 2.95.3 3.3.3 3.4.0 4.0.0 4.1.0
Last reconfirmed: 2006-09-03 21:39:05


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Pinski 2005-11-01 02:49:50 UTC
Testcase:
template<typename _Function>
  void for_each(_Function __f)
{
  __f(1);
}
class locale{};
template<typename SequenceT>
  void trim(SequenceT& Input, const locale& Loc=locale());
int main()
{
  for_each(trim<const int>);
}
-------

I don't know if this is valid or not but guess what ICC also ICEs on this testcase too.
Comment 1 Andrew Pinski 2005-11-12 05:41:03 UTC
Confirmed, this is was just a split out.
Comment 2 Volker Reichelt 2005-11-17 12:04:48 UTC
I think this is a duplicate of PR 24602.
The only difference is the missing copy-ctor here.
Comment 3 Volker Reichelt 2007-07-23 22:08:31 UTC
Since Nathan's patch for PR32839 we get the same error message for PR24602
as for PR24606. This really looks like a duplicate.


*** This bug has been marked as a duplicate of 24602 ***