Bug 24586 - [4.0 regression] ICE in g++.dg/opt/mmx2.C
Summary: [4.0 regression] ICE in g++.dg/opt/mmx2.C
Status: RESOLVED WONTFIX
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.0.3
: P2 normal
Target Milestone: 4.0.4
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-checking, ice-on-valid-code, monitored, ssemmx
Depends on:
Blocks:
 
Reported: 2005-10-30 17:28 UTC by Volker Reichelt
Modified: 2007-02-03 15:50 UTC (History)
3 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed: 2006-09-03 21:39:38


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volker Reichelt 2005-10-30 17:28:19 UTC
Jakub, the testcase g++.dg/opt/mmx2.C you added, causes a segfault
on the 4.0 branch:

g++ -O2 -mmmx -c mmx2.C
mmx2.C: In function 'int main()':
mmx2.C:23: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.

This can also be seen in Kaveh's testresults, for example:

http://gcc.gnu.org/ml/gcc-testresults/2005-10/msg00523.html
http://gcc.gnu.org/ml/gcc-testresults/2005-10/msg01202.html

It looks like --enable-checking is required to trigger the bug.

As this is a new FAIL in the testsuite, I rate this as a regression.

Could you please have a look?
Comment 1 Gabriel Dos Reis 2007-02-03 15:50:19 UTC
Won't fix in GCC-4.0.x