Bug 24572 - [4.0 regression] ICE in gimplify_expr, at gimplify.c:3983
Summary: [4.0 regression] ICE in gimplify_expr, at gimplify.c:3983
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: java (show other bugs)
Version: 4.0.3
: P2 normal
Target Milestone: 4.0.3
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2005-10-28 17:09 UTC by Debian GCC Maintainers
Modified: 2006-01-01 05:22 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Known to work: 4.1.0 4.0.2
Known to fail: 4.0.3
Last reconfirmed: 2005-11-03 09:41:22


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Debian GCC Maintainers 2005-10-28 17:09:42 UTC
seen with 4.0 CVS 20051023, compiling antlr 2.7.5.

/usr/bin/gcj-4.0 -shared --classpath= -fassume-compiled -I./src -I. -I/usr/share/java/antlr.jar -I. -g -O2 -c -o antlr.so /usr/share/java/antlr.jar
antlr/StringUtils.java: In class 'antlr.StringUtils':
antlr/StringUtils.java: In method 'antlr.StringUtils.stripBack(java.lang.String,java.lang.String)':
antlr/StringUtils.java:24: internal compiler error: in gimplify_expr, at gimplify.c:3983
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.

copy of the jar file at http://people.debian.org/~doko/tmp/antlr.jar
Comment 1 Mark Wielaard 2005-11-03 09:41:22 UTC
Confirmed, this prevents gjdoc from building, which used the build just fine with earlier gcj 4.0.x releases.
Comment 2 Andreas Tobler 2005-11-03 20:16:03 UTC
Todays gcc-svn HEAD compiles the jar fine. On ppc darwin.

Todays gcc-svn-gcc-4_0-branch fails with the below bt. Also on darwin.

wolfram:~/Desktop] andreast% gdb /Volumes/export/gcc/gcc-svn/branch/testbin/libexec/gcc/powerpc-apple-darwin8.3.0/4.0.3/jc1
GNU gdb 6.1-20040303 (Apple version gdb-384) (Mon Mar 21 00:05:26 GMT 2005)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "powerpc-apple-darwin"...Reading symbols for shared libraries ..... done

(gdb) set args antlr-2.7.5.jar -fhash-synchronization -fuse-divide-subroutine -fuse-boehm-gc -fnon-call-exceptions -fkeep-inline-functions -feliminate-unused-debug-symbols -fPIC -quiet -dumpbase antlr-2.7.5.jar -auxbase-strip antlr.so -g -O2 -version -fclasspath= -fassume-compiled -o /var/tmp//cchNKeYh.s
(gdb) r
Starting program: /Volumes/export/gcc/gcc-svn/branch/testbin/libexec/gcc/powerpc-apple-darwin8.3.0/4.0.3/jc1 antlr-2.7.5.jar -fhash-synchronization -fuse-divide-subroutine -fuse-boehm-gc -fnon-call-exceptions -fkeep-inline-functions -feliminate-unused-debug-symbols -fPIC -quiet -dumpbase antlr-2.7.5.jar -auxbase-strip antlr.so -g -O2 -version -fclasspath= -fassume-compiled -o /var/tmp//cchNKeYh.s
Reading symbols for shared libraries . done
GNU Java version 4.0.3 20051103 (prerelease) (powerpc-apple-darwin8.3.0)
        compiled by GNU C version 4.0.3 20051103 (prerelease).
GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072
Class path starts here:
    ./
    /Volumes/export/gcc/gcc-svn/branch/testbin/share/java/libgcj-4.0.3.jar/ (system) (zip)

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000010
add_insn_after (insn=0x4b841ea0, after=0x0) at /Volumes/export/gcc/gcc-svn/branch/gcc-4_0-branch/gcc/emit-rtl.c:3377
3377      rtx next = NEXT_INSN (after);
(gdb) bt
#0  add_insn_after (insn=0x4b841ea0, after=0x0) at /Volumes/export/gcc/gcc-svn/branch/gcc-4_0-branch/gcc/emit-rtl.c:3377
#1  0x00131208 in emit_note_after (subtype=-84, after=0x0) at /Volumes/export/gcc/gcc-svn/branch/gcc-4_0-branch/gcc/emit-rtl.c:4156
#2  0x002a0178 in tree_expand_cfg () at /Volumes/export/gcc/gcc-svn/branch/gcc-4_0-branch/gcc/cfgexpand.c:1076
#3  0x0006d7d0 in execute_pass_list (pass=0x47c15c) at /Volumes/export/gcc/gcc-svn/branch/gcc-4_0-branch/gcc/tree-optimize.c:526
#4  0x0006dae0 in tree_rest_of_compilation (fndecl=0x4a9b7080) at /Volumes/export/gcc/gcc-svn/branch/gcc-4_0-branch/gcc/tree-optimize.c:661
#5  0x002c53dc in cgraph_expand_function (node=0x4c586780) at /Volumes/export/gcc/gcc-svn/branch/gcc-4_0-branch/gcc/cgraphunit.c:835
#6  0x002c54d0 in cgraph_assemble_pending_functions () at /Volumes/export/gcc/gcc-svn/branch/gcc-4_0-branch/gcc/cgraphunit.c:307
#7  0x002c5c00 in cgraph_finalize_function (decl=0x4a9b7080, nested=0 '\0') at /Volumes/export/gcc/gcc-svn/branch/gcc-4_0-branch/gcc/cgraphunit.c:399
#8  0x00032690 in end_java_method () at /Volumes/export/gcc/gcc-svn/branch/gcc-4_0-branch/gcc/java/decl.c:2048
#9  0x0004c184 in parse_class_file () at /Volumes/export/gcc/gcc-svn/branch/gcc-4_0-branch/gcc/java/jcf-parse.c:925
#10 0x0004ebbc in java_parse_file (set_yydebug=1266949792) at /Volumes/export/gcc/gcc-svn/branch/gcc-4_0-branch/gcc/java/jcf-parse.c:1423
#11 0x0027c454 in toplev_main (argc=1078864652, argv=0xbffff73f) at /Volumes/export/gcc/gcc-svn/branch/gcc-4_0-branch/gcc/toplev.c:1010
#12 0x00002348 in _start (argc=21, argv=0xbffff5c4, envp=0xbffff61c) at /SourceCache/Csu/Csu-57/crt.c:272
#13 0x000021e8 in start ()
(gdb) 

[wolfram:gcc-svn/branch/objdir] andreast% ./gcc/xgcc -v
Using built-in specs.
Target: powerpc-apple-darwin8.3.0
Configured with: /Volumes/export/gcc/gcc-svn/branch/gcc-4_0-branch/configure --prefix=/Volumes/export/gcc/gcc-svn/branch/testbin --enable-java-awt=gtk,xlib --enable-gtk-cairo --disable-checking --enable-languages=c,c++,java --disable-multilib
Thread model: posix
gcc version 4.0.3 20051103 (prerelease)
Comment 3 Andreas Tobler 2005-11-03 20:35:37 UTC
Forgot to add where it bombs w/o gdb involved:

antlr/Parser.java: In class 'antlr.Parser':
antlr/Parser.java: In method 'antlr.Parser.consumeUntil(int)':
antlr/Parser.java:0: internal compiler error: Bus error
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
Comment 4 Debian GCC Maintainers 2005-11-12 09:35:03 UTC
works with HEAD 20051111
Comment 5 Andrew Pinski 2005-12-13 18:59:46 UTC
This should be fixed by:
http://gcc.gnu.org/ml/gcc-patches/2005-12/msg00218.html
Comment 6 Debian GCC Maintainers 2005-12-14 11:04:51 UTC
works for me

  Matthias