User account creation filtered due to spam.

Bug 24272 - strange link error with ACE
Summary: strange link error with ACE
Status: RESOLVED DUPLICATE of bug 19664
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 4.0.2
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-08 06:03 UTC by Lothar Werzinger
Modified: 2006-03-10 23:36 UTC (History)
17 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
preprocessed file (gziped) (158.31 KB, application/x-gzip)
2005-10-08 06:06 UTC, Lothar Werzinger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lothar Werzinger 2005-10-08 06:03:09 UTC
/opt2/linux/ix86/x86_64-pc-linux-gnu/bin/g++ -v
Using built-in specs.
Target: x86_64-pc-linux-gnu
Configured with: ../gcc-4.0.2/configure --program-suffix=-4.0.2 --enable-__cxa_atexit --enable-languages=c,c++ --prefix=/opt2/linux/ix86 --target=x86_64-pc-linux-gnu --host=i686-pc-linux-gnu --with-sysroot=/opt2/linux/ix86/SuSE-10.0 --enable-version-specific-runtime-libs --enable-clocale=gnu
Thread model: posix
gcc version 4.0.2

/opt2/linux/ix86/lib/gcc/x86_64-pc-linux-gnu/4.0.2/../../../../x86_64-pc-linux-gnu/bin/ld: .shobj/Logging_Strategy.o: relocation R_X86_64_PC32 against `std::basic_ofstream<char, std::char_traits<char> >::basic_ofstream(char const*, std::_Ios_Openmode)@@GLIBCXX_3.4' can not be used when making a shared object; recompile with -fPIC
/opt2/linux/ix86/lib/gcc/x86_64-pc-linux-gnu/4.0.2/../../../../x86_64-pc-linux-gnu/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status
Comment 1 Lothar Werzinger 2005-10-08 06:06:54 UTC
Created attachment 9932 [details]
preprocessed file (gziped)

preprocessed file that is mentioned in the linker error as having created the invalid reference.
Comment 2 Lothar Werzinger 2005-10-08 06:07:43 UTC
/opt2/linux/ix86/x86_64-pc-linux-gnu/bin/g++ -fvisibility=hidden -fvisibility-inlines-hidden -save-temps -W -Wall -Wpointer-arith -m64 -I/opt2/linux/x86_64/include -O3 -g -pipe  -m64 -I/opt2/linux/x86_64/include   -D_REENTRANT -DACE_HAS_AIO_CALLS -D_GNU_SOURCE -DACE_USE_RCSID=0   -I/opt2/linux/x86_64/ACE/1.4.7/ACE_wrappers -I/usr/kerberos/include -DACE_HAS_EXCEPTIONS -D__ACE_INLINE__ -I.. -DACE_HAS_ACE_TOKEN -DACE_HAS_ACE_SVCCONF -DACE_BUILD_DLL  -c -fPIC -o .shobj/Logging_Strategy.o Logging_Strategy.cpp
g++: warning: -pipe ignored because -save-temps specified
Comment 3 Andrew Pinski 2005-10-08 13:42:00 UTC

*** This bug has been marked as a duplicate of 19664 ***
Comment 4 starlight 2006-03-10 23:36:24 UTC
This bug is not a dupliate of bug 19664.  I just applied
'gcc-push-pop-visibility.patch' to gcc 4.0.2 on 'x86_64'
and the problem is still there:

/usr/bin/ld: .shobj/Logging_Strategy.o: relocation R_X86_64_PC32 against `std::basic_ofstream<char, std::char_traits<char> >::basic_ofstream(char const*, std::_Ios_Openmode)@@GLIBCXX_3.4' can not be used when making a shared object; recompile with -fPIC                               

BTW, had to had-edit the patch for three files:

libstdc++-v3/include/tr1/array
libstdc++-v3/include/debug/string
libstdc++-v3/include/std/std_sstream.h