Bug 24166 - compile error (cvs-2005-10-02)
Summary: compile error (cvs-2005-10-02)
Status: RESOLVED FIXED
Alias: None
Product: classpath
Classification: Unclassified
Component: classpath (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: 0.19
Assignee: Thomas Fitzsimmons
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-02 07:52 UTC by YunSong hwang
Modified: 2005-10-25 15:05 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2005-10-02 15:10:22


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description YunSong hwang 2005-10-02 07:52:04 UTC
Making all in lib
make[1]: Entering directory `/home/hys545/class/classpath/lib'
true
top_builddir=.. top_srcdir=.. /bin/sh ./gen-classlist.sh standard
Adding java source files from srcdir '..'.
Adding java source files from VM directory ../vm/reference
/usr/bin/jikes +Pno-shadow +Pno-switchcheck +F -encoding UTF-8 -bootclasspath '' -extdirs '' -sourcepath '' --classpath ../vm/reference:..:../external/w3c_dom:../external/sax:.: -d . @classes

Issued 1 semantic warning compiling "../external/sax/org/xml/sax/helpers/ParserAdapter.java":

   564.                             atts.addAttribute (nsSupport.XMLNS, prefix,
                                                                 ^---^
*** Semantic Warning: Accessing the class field "XMLNS" via an instance is discouraged because the field accessed will be the one in the variable's declared type, not the instance's dynamic type.

Issued 1 semantic warning compiling "../javax/swing/tree/DefaultTreeCellEditor.java":

   100.     public void EditorContainer()
                   ^------------------^
*** Semantic Warning: The name of this method "EditorContainer" matches the name of the containing class. However, the method is not a constructor since its declarator is qualified with a type.

Issued 2 semantic warnings compiling "../javax/swing/plaf/metal/MetalSliderUI.java":

   129.   protected final int TICK_BUFFER = 4;
                              ^-------------^
*** Semantic Warning: Final field "TICK_BUFFER" is initialized with a constant expression and could be made static to save space.


   132.   protected final String SLIDER_FILL = "JSlider.isFilled";
                                 ^------------------------------^
*** Semantic Warning: Final field "SLIDER_FILL" is initialized with a constant expression and could be made static to save space.

Issued 1 semantic warning compiling "../javax/swing/plaf/basic/BasicInternalFrameUI.java":

   172.     protected final int RESIZE_NONE = 0;
                                ^-------------^
*** Semantic Warning: Final field "RESIZE_NONE" is initialized with a constant expression and could be made static to save space.

Found 2 syntax errors in "../javax/imageio/ImageIO.java":

   962.         if (input instanceof spi.getInputClass())
                                        ^
*** Syntax Error: | expected instead of this token


  1010.         if (input instanceof spi.getOutputClass())
                                        ^
*** Syntax Error: | expected instead of this token

Found 1 semantic error compiling "../javax/imageio/ImageIO.java":

   260.     public WriterObjectFilter(ImageReader reader,
                   ^----------------^
*** Semantic Error: The name of the constructor "WriterObjectFilter" does not match the name of the class "TranscoderFilter". Assuming it is a method with missing return type.

Issued 1 lexical warning in "../gnu/java/rmi/registry/RegistryImpl_Stub.java":

    61.     private static java.lang.reflect.Method $method_bind_0;
                                                    ^------------^
*** Lexical Warning: The use of "$" in an identifier, while legal, is strongly discouraged, since itcan conflict with compiler-generated names. If you are trying to access a nested type, use "." instead of "$".

Issued 1 semantic warning compiling "../gnu/java/awt/peer/gtk/GtkDialogPeer.java":

                                       <----------------
    97.             heavyWeightClass = JPopupMenu.class.
    98.                     forName("javax.swing.JPopupMenu$HeavyWeightPopup");
        -------------------------->
*** Semantic Warning: Invoking the class method "forName" via an instance is discouraged because themethod invoked will be the one in the variable's declared type, not the instance's dynamic type.
make[1]: *** [compile-classes] &#50724;&#47448; 1
make[1]: Leaving directory `/home/hys545/class/classpath/lib'
make: *** [all-recursive] &#50724;&#47448; 1
Comment 1 cvs-commit@developer.classpath.org 2005-10-02 11:44:05 UTC
Subject: Bug 24166

CVSROOT:	/cvsroot/classpath
Module name:	classpath
Branch: 	
Changes by:	Mark Wielaard <mark@savannah.gnu.org>	05/10/02 11:27:53

Modified files:
	.              : ChangeLog 
	javax/imageio  : ImageIO.java 

Log message:
	Workarounds for bug #24166
	* javax/imageio/ImageIO.java (filter): Catch IOException in
	canDecodeInput().
	(TranscoderFilter.WriterObjectFilter): Renamed to TranscoderFilter.
	(getImageReadersBySuffix): Use ReaderObjectFilter, not the nonexisting
	ReaderSuffixFilter.
	(createImageInputStream): Test with Class.isAssignableFrom() and for
	foundSpi == null.
	(createImageOutputStream): Likewise and use output, not input.
	(getImageReader): Always return null for now.
	(getImageReaders): Use input, not object.
	(getImageWriters): Rename formatName to format and create a
	WriterObjectFilter with type and format not just object.
	(getImageWriter): Always return null for now.
	(getImageTranscoders): Create TranscoderFilter not ImageTranscoderSpi
	instance.

CVSWeb URLs:
http://savannah.gnu.org/cgi-bin/viewcvs/classpath/classpath/ChangeLog.diff?tr1=1.5077&tr2=1.5078&r1=text&r2=text
http://savannah.gnu.org/cgi-bin/viewcvs/classpath/classpath/javax/imageio/ImageIO.java.diff?tr1=1.8&tr2=1.9&r1=text&r2=text




Comment 2 Thomas Fitzsimmons 2005-10-02 16:58:19 UTC
Fixed on GNU Classpath mainline.  Closing.