Bug 24162 - internal compiler error, make_class_data
Summary: internal compiler error, make_class_data
Status: RESOLVED DUPLICATE of bug 23617
Alias: None
Product: gcc
Classification: Unclassified
Component: java (show other bugs)
Version: 4.0.2
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-01 15:33 UTC by Felix Berger
Modified: 2005-10-03 14:26 UTC (History)
3 users (show)

See Also:
Host:
Target: i486-linux-gnu
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Berger 2005-10-01 15:33:00 UTC
I got the following error output when trying to compile a jar file from the 
limewire project (http://www.limewire.org/): 
 
 
 gcj -v -save-temps core.jar  
Using built-in specs. 
Reading specs from /usr/lib/gcc/i486-linux-gnu/4.0.2/../../../libgcj.spec 
rename spec lib to liborig 
Target: i486-linux-gnu 
Configured with: ../src/configure -v 
--enable-languages=c,c++,java,f95,objc,ada,treelang --prefix=/usr 
--enable-shared --with-system-zlib --libexecdir=/usr/lib 
--without-included-gettext --enable-threads=posix --enable-nls 
--program-suffix=-4.0 --enable-__cxa_atexit --enable-libstdcxx-allocator=mt 
--enable-clocale=gnu --enable-libstdcxx-debug --enable-java-gc=boehm 
--enable-java-awt=gtk --enable-gtk-cairo 
--with-java-home=/usr/lib/jvm/java-1.4.2-gcj-4.0-1.4.2.0/jre --enable-mpfr 
--disable-werror --enable-checking=release i486-linux-gnu 
Thread model: posix 
gcc version 4.0.2 (Debian 4.0.1-9) 
 /usr/lib/gcc/i486-linux-gnu/4.0.2/jc1 core.jar -fhash-synchronization 
-fno-use-divide-subroutine -fuse-boehm-gc -fnon-call-exceptions 
-fno-omit-frame-pointer -fkeep-inline-functions -quiet -dumpbase core.jar 
-mtune=i486 -auxbase core -g1 -version -o core.s 
GNU Java version 4.0.2 (Debian 4.0.1-9) (i486-linux-gnu) 
        compiled by GNU C version 4.0.2 (Debian 4.0.1-9). 
GGC heuristics: --param ggc-min-expand=90 --param ggc-min-heapsize=113113 
Class path starts here: 
    ./ 
    /usr/java/j2sdk1.4.1_03/jre/lib/rt.jar/ (zip) 
    /usr/share/java/libgcj-4.0.2.jar/ (system) (zip) 
java/lang/String.java:18: internal compiler error: in make_class_data, at 
java/class.c:1760
Comment 1 Mark Wielaard 2005-10-01 17:40:39 UTC
Subject: Re:  New: internal compiler error, make_class_data

On Sat, 2005-10-01 at 15:33 +0000, bflat1 at gmx dot net wrote:
> Class path starts here: 
>     ./ 
>     /usr/java/j2sdk1.4.1_03/jre/lib/rt.jar/ (zip) 
>     /usr/share/java/libgcj-4.0.2.jar/ (system) (zip) 
> java/lang/String.java:18: internal compiler error: in make_class_data, at 
> java/class.c:1760

gcj shouldn't crash of course, but are you sure that rt.jar on your
Class path is correct? Kaffe comes with an rt.jar which contains kaffe's
bootstrap classes, some other runtimes also ship with something called
rt.jar. But gcj doesn't. Mixing bootstrap classes from different
compilers/runtimes doesn't work.

Comment 2 Felix Berger 2005-10-01 18:02:43 UTC
Thanks for the hint, removing rt.jar from the CLASSPATH variable fixed this 
problem which was then superseded by the following: 
 
 gcj -v -save-temps core.jar  
Using built-in specs. 
Reading specs from /usr/lib/gcc/i486-linux-gnu/4.0.2/../../../libgcj.spec 
rename spec lib to liborig 
Target: i486-linux-gnu 
Configured with: ../src/configure -v 
--enable-languages=c,c++,java,f95,objc,ada,treelang --prefix=/usr 
--enable-shared --with-system-zlib --libexecdir=/usr/lib 
--without-included-gettext --enable-threads=posix --enable-nls 
--program-suffix=-4.0 --enable-__cxa_atexit --enable-libstdcxx-allocator=mt 
--enable-clocale=gnu --enable-libstdcxx-debug --enable-java-gc=boehm 
--enable-java-awt=gtk --enable-gtk-cairo 
--with-java-home=/usr/lib/jvm/java-1.4.2-gcj-4.0-1.4.2.0/jre --enable-mpfr 
--disable-werror --enable-checking=release i486-linux-gnu 
Thread model: posix 
gcc version 4.0.2 (Debian 4.0.1-9) 
 /usr/lib/gcc/i486-linux-gnu/4.0.2/jc1 core.jar -fhash-synchronization 
-fno-use-divide-subroutine -fuse-boehm-gc -fnon-call-exceptions 
-fno-omit-frame-pointer -fkeep-inline-functions -quiet -dumpbase core.jar 
-mtune=i486 -auxbase core -g1 -version -o core.s 
GNU Java version 4.0.2 (Debian 4.0.1-9) (i486-linux-gnu) 
        compiled by GNU C version 4.0.2 (Debian 4.0.1-9). 
GGC heuristics: --param ggc-min-expand=90 --param ggc-min-heapsize=113113 
Class path starts here: 
    /usr/share/java/commons-logging.jar/ (zip) 
    ../../lib/jars/clink.jar/ (zip) 
    /usr/share/java/libgcj-4.0.2.jar/ (system) (zip) 
 
jc1: out of memory allocating 1342179073 bytes after a total of 492188 bytes 
 
Comment 3 Tom Tromey 2005-10-03 14:26:10 UTC
This is a duplicate.
I'm not sure what is going on with the patch in PR 23617...


*** This bug has been marked as a duplicate of 23617 ***