Bug 24014 - casting int to double with got wrong result
Summary: casting int to double with got wrong result
Status: RESOLVED DUPLICATE of bug 323
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.3.5
: P2 critical
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-22 15:44 UTC by Uwe Strempel
Modified: 2005-09-22 15:48 UTC (History)
1 user (show)

See Also:
Host: i486-pc-linux-gnu
Target: i486-pc-linux-gnu
Build: i486-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Strempel 2005-09-22 15:44:03 UTC
	I've written an macro for log2 calculation to calculate the exponent of one value.
	Than I cast this value to from double to int.
	The 2 values double and int differs. 
	example:
	log2(8) should be 3 but after casting to int its 2.
	This bug could be reproduced on 2 different linux distributions (Debian GNU/Linux and Fedora Core 2) with different compiler versions.

Environment:
System: Linux lux 2.6.9 #2 Tue Dec 28 22:27:56 CET 2004 i686 GNU/Linux
Architecture: i686

	
host: i486-pc-linux-gnu
build: i486-pc-linux-gnu
target: i486-pc-linux-gnu
configured with: ../src/configure -v --enable-languages=c,c++,java,f77,pascal,objc,ada,treelang --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-gxx-include-dir=/usr/include/c++/3.3 --enable-shared --enable-__cxa_atexit --with-system-zlib --enable-nls --without-included-gettext --enable-clocale=gnu --enable-debug --enable-java-gc=boehm --enable-java-awt=xlib --enable-objc-gc i486-linux

How-To-Repeat:
	use this code to reproduce it
	--- code ---
	#include <math.h>
	#include <stdlib.h>
	#define log2(val) (log((val))/log(2.0))
	int main()
	{       
	      int n1=log2(8);
		double d1=log2(8);
		printf("%d %f\n",n1,d1);
		return 0;
	 }
	--- end ---
Comment 1 Uwe Strempel 2005-09-22 15:44:03 UTC
Fix:
	For workaround I implemented a function for log2.
Comment 2 Andrew Pinski 2005-09-22 15:48:13 UTC
This is really not a bug.

This is a dup of 323.

*** This bug has been marked as a duplicate of 323 ***