Bug 23844 - fails to detect "is used uninitialized"
Summary: fails to detect "is used uninitialized"
Status: RESOLVED DUPLICATE of bug 19430
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 4.0.2
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-12 21:51 UTC by marcus
Modified: 2005-09-12 21:55 UTC (History)
1 user (show)

See Also:
Host: x86_64-unknown-linux-gnu
Target: x86_64-unknown-linux-gnu
Build: x86_64-unknown-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments
foo.c (200 bytes, text/plain)
2005-09-12 21:52 UTC, marcus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marcus 2005-09-12 21:51:33 UTC
the following snippet (extracted from WINE) fails to detect 
"is used uninitialized" in msi_maskedit_create_children(). 
 
The problem is likely the very similar looking code somewhere else 
in the inline chain. 
 
4.0 and 4.1
Comment 1 marcus 2005-09-12 21:52:07 UTC
Created attachment 9712 [details]
foo.c

gcc -O2 -Wall -c foo.c

should print "text is used uninitialized" but does not.
Comment 2 Andrew Pinski 2005-09-12 21:55:39 UTC

*** This bug has been marked as a duplicate of 19430 ***