Bug 23653 - lib/Makefile is not portable
Summary: lib/Makefile is not portable
Status: RESOLVED FIXED
Alias: None
Product: classpath
Classification: Unclassified
Component: classpath (show other bugs)
Version: 0.17
: P2 normal
Target Milestone: 0.18
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-31 13:10 UTC by Eric Botcazou
Modified: 2005-09-04 13:57 UTC (History)
1 user (show)

See Also:
Host: *-*-solaris2.*
Target: *-*-solaris2.*
Build: *-*-solaris2.*
Known to work:
Known to fail:
Last reconfirmed: 2005-09-03 19:19:12


Attachments
possible fix for pr (409 bytes, patch)
2005-09-03 19:00 UTC, Andreas Tobler
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Botcazou 2005-08-31 13:10:21 UTC
The error message is:

Making all in classpath
gmake[1]: Entering directory
`/opt/build/eric/gcc/sparc64-sun-solaris2.9/libjava/classpath'
Making all in lib
/bin/find: bad option -path
/bin/find: path-list predicate-list

-path is not a portable option for find.
Comment 1 Mark Wielaard 2005-08-31 14:12:18 UTC
Subject: Re:  New: lib/Makefile is not portable

> -path is not a portable option for find.

Would changing it to -wholename help?

Comment 2 Eric Botcazou 2005-09-01 19:30:23 UTC
> Would changing it to -wholename help?

No, it wouldn't, -wholename is not portable either.
Comment 3 Andreas Tobler 2005-09-01 21:35:42 UTC
I tried 

'find . META-INF -name "CVS" -prune -o -type f -print'
 
on both, solaris and linux, for me it gives the same output as 

'find . META-INF -path \*/CVS  -prune -o -type f -print' on linux.

But maybe I miss a point ?

Btw, sparc solaris10.

On the otherhand, my build did not fail, I only saw the warning.
Comment 4 Andreas Tobler 2005-09-03 19:00:04 UTC
Created attachment 9660 [details]
possible fix for pr

Tried this on gcc cvs head and classpath cvs head. Seems to werk on sparc
solaris10.
Comment 5 Mark Wielaard 2005-09-04 13:57:00 UTC
Tested on x86 GNU/Linux and checked in the fix.
Comment 6 cvs-commit@developer.classpath.org 2005-09-04 15:03:39 UTC
Subject: Bug 23653

CVSROOT:	/cvsroot/classpath
Module name:	classpath
Branch: 	
Changes by:	Mark Wielaard <mark@savannah.gnu.org>	05/09/04 13:55:55

Modified files:
	.              : ChangeLog 
	lib            : Makefile.am 

Log message:
	2005-09-04  Andreas Tobler  <a.tobler@schweiz.ch>
	
	Fix for bug #23653
	* lib/Makefile.am (metafiles): Use find -name -prune not -path.

CVSWeb URLs:
http://savannah.gnu.org/cgi-bin/viewcvs/classpath/classpath/ChangeLog.diff?tr1=1.4640&tr2=1.4641&r1=text&r2=text
http://savannah.gnu.org/cgi-bin/viewcvs/classpath/classpath/lib/Makefile.am.diff?tr1=1.100&tr2=1.101&r1=text&r2=text