Bug 23644 - IA-64 hardware models and configuration options documentation error for 3.4.x and 4.0.x
Summary: IA-64 hardware models and configuration options documentation error for 3.4.x...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.0.1
: P2 normal
Target Milestone: 3.4.5
Assignee: Jim Wilson
URL:
Keywords: documentation
Depends on:
Blocks:
 
Reported: 2005-08-30 21:19 UTC by David H. Gutteridge
Modified: 2005-10-23 22:58 UTC (History)
1 user (show)

See Also:
Host: N/A
Target: N/A
Build: N/A
Known to work: 3.4.5 4.0.3 4.1.0
Known to fail: 3.4.4 4.0.2
Last reconfirmed: 2005-10-08 00:25:17


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David H. Gutteridge 2005-08-30 21:19:02 UTC
Hello,

I've filed this under web, though obviously it applies to your info pages as
well, I assume you generate everything from the same source, so this may be
better filed somewhere else.  (How come you don't have a documentation component
to choose for bug reports?)

For both gcc 3.4(.4) and 4.0(.1), under IA-64 options, your documentation states:

"-mtune-arch=cpu-type
    Tune the instruction scheduling for a particular CPU, Valid values are
itanium, itanium1, merced, itanium2, and mckinley."

The correct option is specified as -mtune=cpu-type, as is noted here (under the
IA-64 heading):

http://gcc.gnu.org/gcc-3.4/changes.html

"Tuning code for the Itanium 2 processor has been added. The generation of code
tuned for Itanium 2 (option -mtune=itanium2) is enabled by default now. To
generate code tuned for Itanium 1 the option -mtune=itanium1 should be used."

Regards,

David H. Gutteridge
Comment 1 Andrew Pinski 2005-08-30 21:36:48 UTC
(In reply to comment #0)
>(How come you don't have a documentation component to choose for bug reports?)

Because that would not make sense as there is a keyword for documentation and documentation 
belongs to the component maintainer.
Comment 2 CVS Commits 2005-10-07 23:57:42 UTC
Subject: Bug 23644

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	wilson@gcc.gnu.org	2005-10-07 23:57:36

Modified files:
	gcc            : ChangeLog 
	gcc/doc        : invoke.texi 

Log message:
	Fix typo in docs.
	PR target/23644
	* doc/invoke.texi (IA-64 Options, item -mtune): Renamed from
	-mtune-arch.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&r1=2.10120&r2=2.10121
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/doc/invoke.texi.diff?cvsroot=gcc&r1=1.684&r2=1.685

Comment 3 CVS Commits 2005-10-08 00:13:10 UTC
Subject: Bug 23644

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-4_0-branch
Changes by:	wilson@gcc.gnu.org	2005-10-08 00:13:07

Modified files:
	gcc            : ChangeLog 
	gcc/doc        : invoke.texi 

Log message:
	Fix typo in IA-64 option docs.
	PR target/23644
	* doc/invoke.texi (IA-64 Options, item -mtune): Renamed from
	-mtune-arch.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-4_0-branch&r1=2.7592.2.452&r2=2.7592.2.453
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/doc/invoke.texi.diff?cvsroot=gcc&only_with_tag=gcc-4_0-branch&r1=1.583.2.26&r2=1.583.2.27

Comment 4 CVS Commits 2005-10-08 00:22:24 UTC
Subject: Bug 23644

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_4-branch
Changes by:	wilson@gcc.gnu.org	2005-10-08 00:22:20

Modified files:
	gcc            : ChangeLog 
	gcc/doc        : invoke.texi 

Log message:
	Fix typo in IA-64 options docs.
	PR target/23644
	* doc/invoke.texi (IA-64 Options, item -mtune): Renamed from
	-mtune-arch.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=2.2326.2.919&r2=2.2326.2.920
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/doc/invoke.texi.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.390.2.42&r2=1.390.2.43

Comment 5 Jim Wilson 2005-10-08 00:25:17 UTC
Mine. IA-64.  Confirmed.  A typo in the patch adding docs for this option.
Comment 6 Jim Wilson 2005-10-08 00:31:11 UTC
Fixed on the gcc-3.4.x branch, the gcc-4.0.x branch, and mainline (gcc-4.1).